1. AC Question's Avatar
    I have an Archos 50c Platinum which can connect to the 3G internet using 1&1 Vodafone in Germany.

    Now I am in the US and bought a Consumer Cellular SIM card which uses the T-Mobile network.

    All I ever get now is EDGE, even though 3G should be available in my area.

    The device specs say:

    WCDMA / 3G freqs: 900/2100 MHz
    GSM / GPRS / EDGE freqs: SIM 2 2G (850 / 1800 MHz), 3G (900 / 1800 / 1900 MHz)
    Data Rates: HSPA+ : 21Mbps / 5.76Mbps

    I am using the same SIM slot as before, and the frequencies should also be fine.

    What am I missing? Does it have to do with the access point settings? How do I get 3G with this device in the US?
    03-29-2016 09:23 PM
  2. Feldon's Avatar
    I looked up your phone on WillMyPhoneWork.net - Check if your phone works on a network

    Your Archos 50c Platinum has 3G (GSM) frequencies of 900 and 2100.
    Unfortunately, AT&T uses 3G (GSM) frequencies of 850 and 1900.

    You will not be able to use this phone at 3G speed in the USA.
    03-29-2016 10:50 PM

Similar Threads

  1. Google Now, voice control and bluetooth....AGAIN
    By Frank Alberta in forum Samsung Galaxy S7 edge
    Replies: 10
    Last Post: 12-05-2016, 04:47 PM
  2. Replies: 1
    Last Post: 03-30-2016, 02:40 PM
  3. Replies: 1
    Last Post: 03-30-2016, 02:35 AM
  4. How do i recover my deleted files from audio manager
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2016, 02:30 AM
  5. Cant view pdf in chrome on android
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-29-2016, 09:16 PM
LINK TO POST COPIED TO CLIPBOARD