1. AC Question's Avatar
    I have been using overdrive app for several years on my 1 Gen Fire.

    Recently the app was upgraded automatically to (I believe) one for Fire HD. It works but doesn't have some fratures of the earlier one, which I want.

    Returned to Amazon App store to find that there are two versions; one for 1 Gen and one for others. When trying to download the 1 Gen version, Amazon says my device is "not compatible"!.

    What happened, and how to I get back earlier features I like (like sleep timer)?
    04-06-2016 12:25 PM
  2. itguyjax8430's Avatar
    I have been using overdrive app for several years on my 1 Gen Fire.

    Recently the app was upgraded automatically to (I believe) one for Fire HD. It works but doesn't have some fratures of the earlier one, which I want.

    Returned to Amazon App store to find that there are two versions; one for 1 Gen and one for others. When trying to download the 1 Gen version, Amazon says my device is "not compatible"!.

    What happened, and how to I get back earlier features I like (like sleep timer)?
    Welcome to Android Central!

    Did you also update your devices software?
    04-11-2016 08:02 AM

Similar Threads

  1. Do not disturb - go silent AND dark at night?
    By chadecoen in forum Samsung Galaxy S7
    Replies: 5
    Last Post: 05-22-2016, 10:10 PM
  2. website and App are terrible
    By lgossin in forum Site Feedback & Help
    Replies: 9
    Last Post: 04-13-2016, 10:10 AM
  3. How do i transfer data and apps onto SD card?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-11-2016, 07:57 AM
  4. Replies: 1
    Last Post: 04-06-2016, 11:24 AM
LINK TO POST COPIED TO CLIPBOARD