1. xSChaos's Avatar
    Hi , I own a Xperia Z2 , and it's has issue to be detected in my computer... let me explain what happen :

    When I plug USB it's try to detect it , depending on port it may be recharging my phone or not ..

    I can connect the phone (but it won't show in any panel) , Connecting the phone as MTP does not work , but MSC does work with no issue , also debug does (with both ways)

    When I try to make it install back drivers it's say error 19 , when I do manual install of drivers it's say error 10...so if anybody could help ;/...

    Edit : As I'm unable to find the answer button anywhere on the page I'll edit main post ;

    I already checked both post earlier and none worked , I even try on getting on with a VM which failed to (The VM detected the phone but did not work , I had it worked in past)

    Again sorry There is no answer button so I'll again edit main post :

    This is under Windows 10 64bits , I've already removed several time the USB drivers for any others phone , I've try to install xperia z2 manual drivers also but it did say Error 10... (there an issue with WPD and mtp drivers which both say error 19
    04-10-2016 02:58 PM
  2. H3aTeRzz's Avatar
    Hi there!

    I've provided a couple of links for your to look over. Let us know if they're not helpful.

    Chris

    https://talk.sonymobile.com/t5/Xperi...lp/td-p/715825

    https://talk.sonymobile.com/t5/Xperi...le/td-p/888498
    04-10-2016 04:08 PM
  3. H3aTeRzz's Avatar
    Hi

    Do you have another PC you can plug into, to see if the same error occurs?
    04-11-2016 08:05 AM
  4. itguyjax8430's Avatar
    Hi , I own a Xperia Z2 , and it's has issue to be detected in my computer... let me explain what happen :

    When I plug USB it's try to detect it , depending on port it may be recharging my phone or not ..

    I can connect the phone (but it won't show in any panel) , Connecting the phone as MTP does not work , but MSC does work with no issue , also debug does (with both ways)

    When I try to make it install back drivers it's say error 19 , when I do manual install of drivers it's say error 10...so if anybody could help ;/...

    Edit : As I'm unable to find the answer button anywhere on the page I'll edit main post ;

    I already checked both post earlier and none worked , I even try on getting on with a VM which failed to (The VM detected the phone but did not work , I had it worked in past)
    I would try getting a new set of drivers form Sony's website to see if that will update them and fix the issue.
    H3aTeRzz likes this.
    04-11-2016 08:26 AM
  5. LeoRex's Avatar
    Not seeing what's going on with the computer, my guess is that the drivers are all fouled up on the PC. I would try to go into Device Manager and USBDeview and remove the entry for your device (Device Manager) and in USBDeview remove any "Android ADB Interface", "Samsung USB", "Google USB" or anything else that matches your particular phone model... tread lightly though.

    Reboot and then try to reinstall the drivers.

    I had a laptop that I couldn't get ADB functioning... at all... no matter what I did, no matter what I uninstalled/installed/updated, I couldn't my defice fully recognized. It happens... Windows does some screwball things with drivers, including piling them up on top of each other... when you upgrade a driver, you aren't upgrading anything, you are just loading a new version. The old versions linger like a bad smell in the interest of backwards compatibility.
    04-11-2016 08:31 AM
  6. Golfdriver97's Avatar
    Welcome to the forums. Is this a Windows or a Linux PC?
    H3aTeRzz likes this.
    04-11-2016 09:24 AM

Similar Threads

  1. Cannot access my phone anymore
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 01-20-2017, 04:24 PM
  2. Replies: 1
    Last Post: 04-13-2016, 03:19 PM
  3. Replies: 1
    Last Post: 04-13-2016, 03:14 PM
  4. Is com.android.services is a Trojan as stated by F-Secure ?
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 04-12-2016, 01:35 PM
  5. why can't login in facebook from sony xperia z
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-12-2016, 04:51 AM
LINK TO POST COPIED TO CLIPBOARD