1. AC Question's Avatar
    Hi everyone, good evening! I hope everyone's doing fine today. Sorry if this ends up lengthy, I just wanna make sure I don't leave anything out.

    My device is a Moto G2 2014, android 6.0, rooted.

    Today I wanted to play some music on my phone and to my surprise the songs were cutting every 3 seconds or so. It was working fine yesterday. I thought it was my headphones dying, but I tested them on other devices and they are fine.

    Ok, so here's the problem: everytime I lock the phone (by lock I mean locked and screen off) or when the screen simply goes off when it's playing music, the cutting begins. It's rather annoying. When the screen is on (even if device is locked), the music plays normally and music also plays normally on speaker mode, even if the screen is off. If the device is charging, music plays normally as well even if screen is off.

    (I sound like a parrot, I know.)

    I've been looking for answers on Google and I can't seem to find a solution, so I thought I should ask here. From what I read, it seems that the problem is the powersaving mode, but here's what I've done so far (following other threads' and websites' suggestions) and no luck yet:

    - I've restarted my phone.
    - Fully charged it, still no luck (when it's charging and the screen is off, music plays normally).
    - Disabled powersave mode, disabled a few apps from battery optimization (mostly the ones I thought had anything to do with music, like audio effects, google play music, android system).
    - I've tried several media players (Google Play Music, RocketPlayer, BSPlayer, Poweramp).
    - I've tried increasing the audio buffer (I think that's what it's called) on Poweramp and it didn't help (I read people saying it would help).
    - I've enabled Downloaded Only option on Google Play Music (even though the music i wanted to listen was already in my SD card).
    - I've restarted my phone after all these steps, and also tested them before restarting.

    I know I should try a factory reset, but I really would like to try to solve this before resorting to that. So, anyone would know anything about this, or am I doomed to factory reset it? =(

    Thanks in advance!
    06-08-2016 06:54 PM
  2. nacheoreom's Avatar
    Even though I didn't get any answers, I thought I should come and say that I somehow managed to find what was going on (even though it's kind of embarrassing to admit that I hadn't tried it before):

    After factory resetting three times, and after re-installing the ROM a few times (because TWRP kept bricking my phone for some reason) and absolutely no luck, I managed to find out that the problem was indeed my pair of headphones, except like I said on my original post, it was working fine on other devices, but it wasn't on my phone (which is weird because I've been using it for a while). What I didn't do, HOWEVER, was to test my phone with another pair of headphones (which in my defense I didn't have at the time =P) and the music was playing fine. If anything now after all the resets and reinstalls, the music cuts with the screen on as well. Way to go to make things worse, I know, I know.

    On a somewhat unimportant note, the music wasn't playing at all on cheap headphones either, so my guess is that my problem is probably both my pair of headphones and the outlet plug of my device.

    Hope this helps someone in the future, and don't be oblivious like I am before resetting!

    TL;DR: Problem was on headphones and probably the outlet jack plug as well; device is playing music normally with a different pair of headphones, and didn't work at all with cheap ones.

    Have a good day!
    06-09-2016 06:49 PM

Similar Threads

  1. Android N on the M10?
    By murphcid in forum HTC 10
    Replies: 15
    Last Post: 06-24-2016, 09:20 AM
  2. Replies: 1
    Last Post: 06-15-2016, 04:38 AM
  3. How to stop and get rid of AdSuppy ads
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-08-2016, 06:40 PM
  4. Why is Now On Tap not responding even though it is enabled?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-08-2016, 06:34 PM
  5. Why is Now On Tap not responding even though it is enabled?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-08-2016, 06:31 PM
LINK TO POST COPIED TO CLIPBOARD