1. AC Question's Avatar
    I have Android version 4.4.2 and Play Services 8.7.03 build 265410-034. I am getting a message that I need to you Google Play Services.

    What version update should I use?
    07-06-2016 11:11 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! What is telling you to update? Google Play Services should be updating on its own.

    My 6P is currently on 9.2.56.
    07-06-2016 01:27 PM

Similar Threads

  1. Replies: 2
    Last Post: 07-06-2016, 03:46 PM
  2. I have a problem "Unfortunatley telecom service stopped"
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2016, 01:32 PM
  3. How do I get Message content on Samsung Galaxy S7 Edge Feed?
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 1
    Last Post: 07-06-2016, 01:28 PM
  4. What is going on with my Droid maxx 2?
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 07-06-2016, 11:33 AM
  5. Replies: 0
    Last Post: 07-06-2016, 10:48 AM
LINK TO POST COPIED TO CLIPBOARD