1. AC Question's Avatar
    I'm trying to update my android phone from version 4.3, but whenever it tries to scan for updates, it says it cannot communicate with the servers. However, I can use google play and other things as usual.
    07-09-2016 08:31 PM
  2. hallux's Avatar
    What phone? If the phone hasn't been updated from 4.3 yet it's likely there won't be a new version available.
    07-10-2016 07:55 AM
  3. TheForgotteOne's Avatar
    It's a Hydro Life phone by Kyocera
    07-10-2016 10:27 AM
  4. anon(632115)'s Avatar
    That is the latest firmware
    07-10-2016 10:36 AM
  5. TheForgotteOne's Avatar
    Then wouldn't it just say that the device is up to date? Instead of saying it cannot communicate with the servers?
    07-10-2016 10:49 AM
  6. anon(632115)'s Avatar
    That would be normal but you may get the message because of poor support or maybe kyocera has ceased to tradr
    07-10-2016 10:52 AM
  7. TheForgotteOne's Avatar
    Ah okay, thank you!
    07-10-2016 10:54 AM

Similar Threads

  1. Replies: 0
    Last Post: 07-09-2016, 08:24 PM
  2. Replies: 1
    Last Post: 07-09-2016, 08:10 PM
  3. how to add international address to MM Contact App
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-09-2016, 08:06 PM
  4. How much does it cost to replace my galaxy s5 screen?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-09-2016, 08:04 PM
LINK TO POST COPIED TO CLIPBOARD