1. AC Question's Avatar
    Since some update some time ago (not sure if this is a Samsung update or an AT&T update), if I or my phone decide to try to connect to a WiFi connection that requires login via a browser, my phone pops up a note, titled "Connection Status," that says: "Oops! To access Wi-Fi from this hotspot, you may need to accept terms of use or log in. Open browser to continue?" with "Yes" and "Cancel" buttons.

    I don't want my phone to do this. The popup is annoying and disruptive for multiple reasons. This "feature" is badly designed in multiple ways. I want to decide for myself when/if to open a browser and try to log in, without a disruptive popup from my phone regarding the circumstances. (Not to mention that the "Oops!" wording of the message is condescending.)

    How do I disable the system from popping up this message?

    Thanks!
    07-23-2016 02:24 PM
  2. N4Newbie's Avatar
    Go to Settings -> WiFi, tap on the offending name and then tap "Forget".

    It should no longer automatically try to connect to that network.

    Posted via the Android Central App
    07-23-2016 02:50 PM
  3. Yaron S's Avatar
    That doesn't resolve the broader issue. I don't want to have to make it "forget" the hotspot every time. There are times when I do want to connect to a hotspot of that name. Besides, there are circumstances in which the feature can even interrupt you while you're in the process of logging in to the hotspot, if it's a somewhat kludgey process, e.g. at some airports. The list goes on re how this "feature" can be ridiculously annoying and disruptive.

    Bottom line, I'm not looking for a bandaid or a workaround. I want to disable this darn "feature."

    Thanks!
    07-23-2016 04:09 PM
  4. N4Newbie's Avatar
    Sorry but there is only one solution and I gave it to you above.

    Your phone will always try to connect to "known" networks when in range.

    What is the name of this network? Some networks of this type have an app available which can automatically and silently perform the login sequence.

    Posted via the Android Central App
    07-23-2016 07:33 PM
  5. Yaron S's Avatar
    I'm fine with the phone trying to connect to the "known" network. What I'm not fine with is the new "feature," that was added lately, that, if the network requires logging in through a browser, the phone pops up the "Oops! Bla bla bla" popup, no matter what I might be in the middle of doing (e.g., composing an e-mail); and if I hit "cancel" instead of "Yes," it will (idiotically) turn off my WiFi. Also, if the login process takes too long (e.g., as in the example I gave, to get online on certain free WiFi services at airports), it'll turn off the WiFi while I'm in the middle of trying to get on the network, or, pop up the "Oops! Bla bla" popup while I'm in the middle of logging onto the network (and then hitting "Yes" starts the process over in a new tab while hitting "Cancel" turns off the WiFi). That's not the only example of ways in which this "feature" (I mean the "Oops! Bla bla" popup) is annoying - far from it.
    07-23-2016 09:18 PM
  6. N4Newbie's Avatar
    You don't have to like it, but that is the way it works and - other than complain to Google and your phone's manufacturer, you really don't have a choice in the matter other than to a) "Forget" the network as I indicated above or b) disable Wi-Fi altogether except during those times when you want it.
    07-24-2016 06:10 AM
  7. Yaron S's Avatar
    Thank you, N4Newbie, for the highly informative lecture. It was very useful in root-causing the problem.

    It turns out that the culprit is the "AT&T Smart WiFi" app - a recent update to the AT&T software probably introduced this profoundly misdesigned "feature" - which was active even though I did not have "AT&T Smart WiFi" turned on in Settings->Device->Accessibility (why the "AT&T Smart WiFi" option is under "Accessibility" is a mystery to me). Apparently some functionality of the "AT&T Smart WiFi" app remain active regardless of the state of the Settings option. I fixed the problem by "turning off" the actual app in the application manager (I'd uninstall it if I could, but it's part of the bloatware package on my phone, and I do not root my phones).
    07-24-2016 03:39 PM
  8. EdoubleM02's Avatar
    Hey Yaron S,
    I just wanted to say thank you for telling me how to turn off that incredibly annoying pop up. It just wouldn't stop. Everything was constantly being interrupted and I would have to open up a new browser every single time and then the pop up would show right up again. You have saved me from a hellish online phone experience. Luckily I was able to uninstall the whole app from my Samsubg Galaxy S6 Edge. I guess it wasn't part of the mandatory initial software bundle for me. Yay!!




    Thank you, N4Newbie, for the highly informative lecture. It was very useful in root-causing the problem.

    It turns out that the culprit is the "AT&T Smart WiFi" app - a recent update to the AT&T software probably introduced this profoundly misdesigned "feature" - which was active even though I did not have "AT&T Smart WiFi" turned on in Settings->Device->Accessibility (why the "AT&T Smart WiFi" option is under "Accessibility" is a mystery to me). Apparently some functionality of the "AT&T Smart WiFi" app remain active regardless of the state of the Settings option. I fixed the problem by "turning off" the actual app in the application manager (I'd uninstall it if I could, but it's part of the bloatware package on my phone, and I do not root my phones).
    10-23-2016 05:02 PM
  9. sydneycooper1979's Avatar
    Ladies and gentlemen, please keep discussion productive and on topic. Personal attacks, insults, taking threads off topic and other disruptive posting behaviors are not acceptable. If you do not like a post, please behave like an adult and move on, or if you feel it violates the forum rules, please report it. At no point should members be calling each other out in posts. Thanks.
    belodion likes this.
    10-23-2016 05:40 PM
  10. jocelyn mel's Avatar
    Oh Boy this has really been a headache. It just keeps interrupting phone calls, browsing and messaging. I'm not sure of its benefit anywhere! It's been really hard to trouble shoot. Epic Fail.
    11-09-2016 10:31 AM
  11. daimne's Avatar
    Oh Boy this has really been a headache. It just keeps interrupting phone calls, browsing and messaging. I'm not sure of its benefit anywhere! It's been really hard to trouble shoot. Epic Fail.
    After i disabled att wi fi app it disabled my home networks as well. hope the main issue with oops gone.
    thank you for the solution.
    11-16-2016 04:25 AM
  12. BobRubano's Avatar
    This is a ridiculous option, if it really isn't optional. Driving down the road with my GPS I get interrupted constantly as I drive thru hot spot zones. I tried turning off Wi-Fi in settings, but this program seems to turn it back on when it detects a Wi-Fi signal. Is there any hope of getting rid of it???
    11-30-2016 12:15 PM
  13. BobRubano's Avatar
    UPDATE: I just went into app mgr and reverted AT&T Smart Wi-Fi back to the "default app" I liked the auto connect to AT&T hot spot feature and really didn't want to give it up entirely. So far I've not received any pop-ups for the last 15 min or so (which normally would have been at least 2-3 of them!!). Also turned off auto updates so it doesn't reinstall itself!! Hopefully AT&T will fix this issue soon!!
    11-30-2016 12:28 PM
  14. Rukbat's Avatar
    The "feature" of logging into a hotspot isn't in the phone at all - it's part of the hotspot software. You can't disable it on the phone because there's nothing there to disable. (AT&T won't change anything - if you want to use their hotspot - or any hotspot that requires a login - you'll get a page or notice like that. It's how the internet works.)
    11-30-2016 03:15 PM
  15. Michelle Faustermann's Avatar
    Thank you, YaronS. That popup was driving me crazy!
    02-13-2017 07:15 AM
  16. Llgwright's Avatar
    Thank you Yaron.
    This was making me crazy.
    Rock on
    Laura
    02-27-2017 11:11 PM
  17. Doug Strohl's Avatar
    Thank you much. The pop was annoying, true, but the bigger problem is that it was auto disconnecting from my sony a6000 while I was trying to do remote control. It was driving me batty. I don't have an AT&T phone (I am on AT&T) so it let me uninstall that app no problem.
    03-17-2017 09:27 PM

Similar Threads

  1. How do you unlock an S7 when it just freezes up?
    By AC Question in forum Ask a Question
    Replies: 12
    Last Post: 08-04-2016, 04:47 PM
  2. Should i ditch my nexus 10 tablet?
    By Medicine Wolf in forum General News & Discussion
    Replies: 2
    Last Post: 07-24-2016, 05:49 PM
  3. phone auto dims but won't snap back
    By jasperlin in forum Nexus 6P
    Replies: 4
    Last Post: 07-23-2016, 08:43 PM
  4. Replies: 0
    Last Post: 07-23-2016, 02:17 PM
  5. My camera will not focus
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-23-2016, 01:58 PM
LINK TO POST COPIED TO CLIPBOARD