07-27-2016 12:48 PM
28 12
tools Reply
  1. AC Question's Avatar
    My Samsung Galaxy Alpha (Lollipop 5.0.2) screen always goes black during a call. I often have conference calls with the speaker on, I rarely actually hold the phone up to my ear. When the call starts, the screen almost immediately goes dark and I have to tap it every couple of seconds to keep it on. I like to use my phone frequently when on calls and like to see the time, notification bar etc. without having to tap every couple seconds. I wouldn't care about this if I weren't on work calls for 6 hours out of every day.

    I've tried apps with no luck (the best was 'Screen On' but it doesn't work for this purpose). My phone isn't rooted but debating looking into rooting if it can fix this error.

    My settings do not give the option to 'turn off proximity sensor' so I am stuck with this issue. Short of just buying a new phone, does anyone have any ideas on how to fix this?

    Thanks!
    07-25-2016 02:54 PM
  2. Javier P's Avatar
    Welcome to the forums. Are you using a screen protector? Sometimes they can interfere with the proximity sensor.
    07-25-2016 03:00 PM
  3. can83's Avatar
    Thanks for your reply. I do not use any type of screen protector or case on my phone.
    07-25-2016 03:06 PM
  4. Javier P's Avatar
    Thanks for registering! I'll get in touch with the moderators and see if they can move this thread to the Galaxy Alpha forum. It's possible that there's some specific setting for this model and it'll be easier getting feedback from other owners.
    07-25-2016 03:12 PM
  5. GRIMWALD's Avatar
    What happens if as soon as you connect your call, you turn the device screen face down on a table?
    Can you also adjust your screen time out to a longer duration?
    GRIM
    07-25-2016 03:26 PM
  6. can83's Avatar
    Thanks Javier - my issue is the Alpha forum has so few visitors I fear my post will get lost. But here's hoping.

    Grimwwald, the screen automatically turns off if face down or face up. The screen time duration is set to 10 minutes, seems to make no difference when on a call.

    Is there not a setting somewhere for calls? I believe in earlier versions this was an easy fix but the Lollipop OS removed it.
    07-25-2016 03:44 PM
  7. GRIMWALD's Avatar
    Do you actually need the screen to be on while talking or does it disconnect the call also?

    GRIM
    07-25-2016 03:49 PM
  8. can83's Avatar
    It doesn't disconnect the call but I need the screen on for multi-tasking. This is my work phone and I am frequently looking at documents when talking and having to tap the screen every 2 seconds makes reading very tough.
    07-25-2016 03:55 PM
  9. GRIMWALD's Avatar
    Is this is something new, have you downloaded any new apps which may be causing a conflict.?
    The only other thing in my bag of knowledge, would be to do a reset.
    If your device has the ability to do just a settings reset, you could try that first but I think a full factory reset could be in order, make sure any and all backups are current.

    GRIM
    07-25-2016 04:07 PM
  10. can83's Avatar
    Thanks again. This problem has always be here, even before downloading many apps. I fear a reset but will soon I guess. Can anyone think of any apps that might keep the screen on always?
    07-25-2016 04:23 PM
  11. GRIMWALD's Avatar
    Check in your setting under Developer options, there may be a setting to keep the device awake while charging.
    This in my opinion is a patch at best but if you are actively using it for six hours of conference calls, it my help.

    GRIM
    07-25-2016 04:39 PM
  12. AlphaTango414's Avatar
    Use THIS APP to test your proximity sensor. May have a faulty sensor.
    07-25-2016 04:42 PM
  13. can83's Avatar
    The app seems to show the sensor working. When I put my phone 2 inches or closer, the app shows a 'NEAR' status, when further than 2 inches the app shows 'FAR'
    07-25-2016 05:09 PM
  14. TJA3500's Avatar
    You could turn on smart stay if it is not on already.
    On my old S4 I could go to phone > menu > settings and deselect "turn off screen during calls".
    07-25-2016 08:28 PM
  15. B. Diddy's Avatar
    Does this happen in Safe Mode? If not, then something you installed is probably causing the issue (which means you'd have to uninstall apps one by one until the problem disappeared). Problems with the Samsung Galaxy Alpha and how to fix them
    AlphaTango414 likes this.
    07-25-2016 10:47 PM
  16. can83's Avatar
    Crazy - I tried Safe Mode and it STILL goes dark when on a call. All the apps are disabled and the problem still occurs. The screen always stays on for 2-3 seconds, then goes dimmed for 2-3 seconds then goes completely off. If I wait too long to wake it, the phone locks and I need to unlock before I can do anything again.

    How is this error possible? I want to do a factory reset but wouldn't Safe Mode have accomplished the same thing?

    Thanks
    07-26-2016 08:47 AM
  17. B. Diddy's Avatar
    Do you have any power saving modes turned on? Or, if Smart Stay is turned on, turn it off. If Smart Stay is on and detects that you're not looking at the screen, it'll turn off the screen.
    Javier P likes this.
    07-26-2016 12:11 PM
  18. GRIMWALD's Avatar
    If you want to try some more testing I came across some interesting info
    "Testing your phones sensor
    Try and run a proximity test on the device. Here are some codes that might give you the option to run a test on the sensor if you’re having this issue on a Smartphone. Go to your dial pad as though you are going to type a telephone number but instead of a telephone number try typing these codes.

    *#7353# will access the Device Diagnostic Tool on Samsung phones and some other Smartphones excluding HTC often there is a proximity sensor test option shown here.

    *#*#3424#*#* can be used to open the Device Diagnostic Tool on an HTC Android phone, some HTC phones show an option to test the proximity sensor through this diagnostic tool, some HTC phones don’t.

    *#*#0588#*#* will also run a Proximity Sensor Test on some Smartphones.

    If you’re interested in other fun codes for your smartphone you can check out Some Useful and Interesting Codes for Smartphones.

    If none of these codes worked on your phone, or you're not sure if the sensor passed the test, or if you’re still getting a black screen after phone calls or cant end calls, then just make a call and hold your hand over the top of the display and see if the screen locks or turns into a black screen. Then remove your hand from the top of the phone and see if the screen comes back, if it does your sensor is working.

    Just keep an eye on the top area of the phone above the display. If the sensor has oil from your skin or makeup covering it then it might not work correctly. Also make sure if you have a case, especially one that might not be made specifically for the phone you’re using, make sure it’s not covering the sensor either."

    Link: Phone stuck on a black screen during or after a call? Here’s the Fix | Smart Mobile Phone Solutions

    GRIM
    B. Diddy likes this.
    07-26-2016 12:42 PM
  19. can83's Avatar
    B.Diddy - you are an (almost) genius. I did have a power saving mode on but forgot about it since it was months ago. I turned this mode off and the screen stays on longer during a call (exactly 20 seconds) but still goes dark. Making progress....

    Grim - I tried the diagnostic tests and my sensor is working, no issue on that front.

    Thanks
    B. Diddy likes this.
    07-26-2016 05:00 PM
  20. B. Diddy's Avatar
    Ok, now go to your Settings>Display menu and see if you can adjust the screen timeout to longer.
    07-26-2016 05:04 PM
  21. GRIMWALD's Avatar
    If you haven't done this already, remove any screen protector that you have in place and increase your screen brightness to max.
    It may also be an issue with your light sensor (which can be tested for with the codes above) and not your proximity sensor.

    GRIM
    07-26-2016 05:54 PM
  22. can83's Avatar
    No screen protector or case on my phone. I just tried the light sensor and it seems to be working (it says 1 or 0, changes when I cover the sensor every time).

    The screen timeout is at 10 minutes. On a call, the screen still dims after 2 seconds but only goes fully dark at 20 seconds. Still making progress
    07-26-2016 06:12 PM
  23. GRIMWALD's Avatar
    My phone is on MM so I can't check but there used to be an option on older OS's in the phone app. settings, something to the effect of "Always keep on during a call". Have you played with the phone settings directly from the app. settings?

    GRIM
    07-26-2016 06:38 PM
  24. can83's Avatar
    I've looked at every possible setting - it seems the 'keep phone on' and 'proximity sensor' settings were all removed in the lollipop 5 update. Maybe I should roll back my OS?
    07-26-2016 08:39 PM
  25. GRIMWALD's Avatar
    If it is a hardware issue, going back won't help and device security would not be a fun time.
    If it is a software issue, it "Should" be fixable.
    Custom Rom's, I wouldn't recommend, mostly because I don't trust them.
    Maybe it is time to upgrade. The new Samsung Note looks good but I wouldn't want to be the test monkey with the Iris scanner on a work phone.
    My Note 5 works as advertised and have no issues at all. I thought I would miss it not having MHL feature but I don't seem to miss it.
    Good luck, I am out of ideas but I will keep an eye out for any one having similar complaints that has found a solution.

    GRIM
    07-26-2016 09:14 PM
28 12

Similar Threads

  1. Replies: 1
    Last Post: 08-01-2016, 05:17 AM
  2. Replies: 1
    Last Post: 08-01-2016, 05:16 AM
  3. Dropped Galaxy S6, screen black
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-25-2016, 04:35 PM
  4. Replies: 1
    Last Post: 07-25-2016, 02:20 PM
  5. Calendar Dismisses Events on its own
    By dwayne1521 in forum Samsung Galaxy S6
    Replies: 0
    Last Post: 07-25-2016, 02:10 PM
LINK TO POST COPIED TO CLIPBOARD