1. AC Question's Avatar
    I am using the stock charger for my galaxy s6 and on my charger it shows a rating of 5v at 2.0A but when i test it with "Ampere" app, it shows 1020mA maximum. Is it supposed to charge at this speed? I am using a good quality cable with gold plated connectors and 24awg core. I also tried two different wall outlets.
    07-26-2016 05:02 AM
  2. sfoLAX's Avatar
    Hello That's probably normal. It's the phone thar governs the input rate (for want of a better term). At around the middle of the charging cycle, say 50 percent for example, the battery is cooler and has less resistance so the charge rate will be highest, though may still not go above 1.7 - 1.8 mAh iirc.
    I got this from actual experts a while ago.

    It's slower when it's very low, and above 95% especially. It will then occasionally trickle charge between 100 - 98 - 100% when left connected.

    The GSam battery app is useful for rates, temperature, cycles, history and other stuff
    07-26-2016 07:26 AM

Similar Threads

  1. Replies: 1
    Last Post: 08-01-2016, 05:02 AM
  2. Galaxy S5 - Marshmallow 6.0.1 - Unable to connect server
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 07-28-2016, 02:14 AM
  3. samsung galaxy j7
    By Sudu nirosha in forum More Samsung Phones
    Replies: 1
    Last Post: 07-26-2016, 01:08 PM
  4. how to fix port phone won't charge
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-26-2016, 06:29 AM
  5. Replies: 1
    Last Post: 07-26-2016, 06:00 AM
LINK TO POST COPIED TO CLIPBOARD