1. AC Question's Avatar
    I turned the phone on after many years of non-use to see if it was carrier unlocked. I had a non t-mobile sim in. Everything booted fine, then it said I needed to enter a network code because it was locked. I could enter or dismiss. I dismissed. Screen went black and only the buttons along the bottom would light up. Pulled the battery, restarted. It did a normal boot up with logos, animation, and sound then goes to the black screen.

    I have wiped the cache, factory reset, I've reinstalled factory firmware via Odin multiple times. Everything says it's successful but when I reboot it still goes to a black screen after the animation.

    Phone wasn't rooted or anything. Just a regular T959 that I think I had updated to whatever the next version up from factory was via Kies, but that's it. (This shouldn't matter because I took it back down to original when I did the Odin thing 5 times.)

    It's obviously not bricked because I can enter Recovery and Download modes. The screen obviously works because it does the boot up logos and animation. Odin said it was good to go so what's up? I must be missing something.
    08-01-2016 03:48 AM

Similar Threads

  1. Wipe Data/Factory Reset Not Working
    By Amusedcat in forum Samsung Galaxy Tab S 8.4
    Replies: 3
    Last Post: 12-25-2016, 02:31 PM
  2. can't download from CH Play after custom room and root
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2016, 10:38 AM
  3. Replies: 1
    Last Post: 08-01-2016, 05:43 AM
  4. My yu yureka phone only works when it is plugged in
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-01-2016, 03:10 AM
  5. (samsung galaxy s6) Touchscreen not working when battery dies
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-01-2016, 02:02 AM
LINK TO POST COPIED TO CLIPBOARD