1. AC Question's Avatar
    I've seen this asked elsewhere on here, but none of the solutions people have given worked for me. Whenever my phone sleeps, it disconnects from wifi and takes a while to reconnect when I turn it back on. I've checked that the "Keep Wi-Fi on during sleep" option is set to "Always," and I'm in range of the wifi signal I want to connect to. When I look at the wifi settings, it usually says "Saved, Secured" by the network I want to connect to, then changes to "Connecting..." for a little while before going back to "Saved, Secured." Does anyone know how I can fix this?

    Thank you!
    08-01-2016 09:42 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Please consider registering on this forum, if you haven't already, so that you can continue the discussion in the original thread you created. It really helps to have an actual dialogue, rather than having to start another thread as an unregistered guest.

    Does this happen on all wi-fi networks, or just your home network? Do you have Smart Network Switch turned off? Any power saving modes turned on?
    08-01-2016 01:12 PM
  3. Tavanio's Avatar
    It's all wi-fi networks. I had Smart Network Switch on, but tried turning it off and still had no luck. It happens with or without power saving mode.

    Thank you!
    08-01-2016 04:05 PM
  4. GRIMWALD's Avatar
    Under "Data usage" in your settings, select Data and then in the upper right corner select "More". From that drop down menu, check to see if if there has been a restrictions put on any of the networks listed.

    GRIM
    B. Diddy likes this.
    08-01-2016 04:52 PM
  5. B. Diddy's Avatar
    Does it happen in Safe Mode as well? https://support.t-mobile.com/docs/DOC-10696
    08-01-2016 10:20 PM
  6. GRIMWALD's Avatar
    If you are on AT&T, disable the AT&T app,"Smart WiFi"

    GRIM
    B. Diddy likes this.
    08-02-2016 08:17 PM
  7. B. Diddy's Avatar
    If you are on AT&T, disable the AT&T app,"Smart WiFi"

    GRIM
    If I've learned one thing from manufacturer/carrier "features," it's that anything called "Smart" is usually kinda dumb.
    08-03-2016 01:57 AM

Similar Threads

  1. Replies: 3
    Last Post: 08-04-2016, 04:23 PM
  2. my samsung sign on to the device
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-01-2016, 07:47 PM
  3. How do I undelete an email I sent to spam?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-01-2016, 01:15 PM
  4. Replies: 7
    Last Post: 08-01-2016, 12:24 PM
  5. Replies: 1
    Last Post: 08-01-2016, 09:41 AM
LINK TO POST COPIED TO CLIPBOARD