1. AC Question's Avatar
    Hello, when I go to the Google play store and try to install a game it says 'Your device isn't compatible with this version' but I looked at the android requirements for the game and it said you needed android '4.1.1+' and my device is 5.1.1 do you know what could be stopping me from downloading the game
    08-10-2016 07:39 PM

Similar Threads

  1. Replies: 1
    Last Post: 08-10-2016, 09:02 PM
  2. It is Impossible to Delete Contacts
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-10-2016, 07:42 PM
  3. Text to contact name, not number
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2016, 07:29 PM
  4. Replies: 0
    Last Post: 08-10-2016, 07:22 PM
  5. Replies: 0
    Last Post: 08-10-2016, 06:56 PM
LINK TO POST COPIED TO CLIPBOARD