1. jws99's Avatar
    All of a sudden when I was using my phone (Moto G), the SIM card stopped being detected. When I tried to use a couple apps stored on my SD card, I realized that wasn't working either because I got an "App not available" notification. My phone still turns on and off and it can still access WiFi, so I think the battery still works. Rebooting several times and taking the cards in and out did not work either.

    The first possibility I am entertaining is that about half an hour before the cards stopped being detected, I placed my phone on a counter covered in a thin layer of water (1/4 cm) for about 1 second before picking it up and drying it off. I didn't think this was a big deal at the time since the phone kept working for a while, but I left my phone (sans back cover, SD card, and SIM card) in a plastic container full of rice overnight to dry it out. This morning, when I put back both cards, the problem wasn't solved. I put my phone back in the rice in hopes that the problem was I just didn't leave it in long enough.

    I'm not sure what else could have caused the problem since it was very sudden and working before, and it's very unusual for both cards to simultaneously fail. However, I'm also skeptical that such short and minimal contact with water could be sufficient to cause that damage.

    Please help!
    08-11-2016 10:55 AM

Similar Threads

  1. Replies: 4
    Last Post: 08-11-2016, 05:09 PM
  2. Cant see the botton for front and back to camera
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-11-2016, 11:57 AM
  3. Google Now cannot be reached at the moment
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-11-2016, 10:50 AM
  4. Replies: 0
    Last Post: 08-11-2016, 10:33 AM
  5. Replies: 0
    Last Post: 08-11-2016, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD