1. AC Question's Avatar
    Just got the new Note 7 and I'm trying to install Mobile@Work to use for my company's BYOMD program. The application won't install from the app store. Keep getting error message that states: "Your company has set up a work profile. To continue using Mobile@work, please use the badge version installed on your device."
    My work tech support says to call Samsung. Samsung says to call Google. Google says to call MobileIron. MobileIron says to call my work tech support.
    Its a personal phone with no work related stuff on it, so they have nothing to do with it. Can anyone help?a
    08-20-2016 05:49 PM
  2. chanchan05's Avatar
    I'm saying your work tech people are a bunch of lazy guys. They were the ones who setup the system, hence they are the ones who can fix the issue, not Samsung, Google, or whoever Mobileron is. If there is a need to tweak any setting on the phone to make it work, they're the ones who should know what setting because they created the setup in the first place.
    08-20-2016 07:18 PM
  3. N0117859's Avatar
    They didnt set it up. The next step is to open the Mobile@Work app and input the company security info, but if the app won't install on the phone there is no way to input the company info.
    08-21-2016 05:49 PM
  4. chanchan05's Avatar
    They set it up with Mobilework. The error says that your company already has a setup profile.

    They would likely have an installer of the app itself, or you can contact the devs to send you an apk.
    08-21-2016 07:26 PM
  5. d2k1323's Avatar
    I was having the same issue. I factory reset my Note 7 and it solved the issue. Seems like something in the initial setup of the Note 7 is preventing the mobileiron app from working properly.
    08-24-2016 04:35 PM
  6. jonathjl's Avatar
    found an another forum that it was due to the set up the of the "Secured Folder" feature. I uninstalled secured folder and it worked for me. This totally beats a factory reset.
    trassekh likes this.
    08-26-2016 05:49 PM
  7. trassekh's Avatar
    MobileIron app issue / solution | T-Mobile Samsung Galaxy Note 7

    You need to uninstall the secure folder.

    Go into your secure folder, select settings, then uninstall the secure folder. It is controlled by samsung Knox, which won't allow MobileIron work properly.
    Once you remove the secure folder, mobileiron works just fine.

    It took me a couple of weeks to figure this out.
    09-01-2016 11:03 AM

Similar Threads

  1. Unable to upload video to facebook using moto g4
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 08-31-2016, 06:31 PM
  2. How to resolve layout object/method references in ActivityMain.java
    By jonmelvin in forum Software Development and Hacking
    Replies: 1
    Last Post: 08-21-2016, 04:43 AM
  3. Former S7 Edge users. How would you compare the Note 7?
    By ThrottleJohnny in forum Samsung Galaxy Note 7
    Replies: 9
    Last Post: 08-20-2016, 08:05 PM
  4. What app i need to mirror my zte phone to my hdtv
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-20-2016, 05:37 PM
  5. how to make the s5 wireless charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-20-2016, 05:30 PM
LINK TO POST COPIED TO CLIPBOARD