1. AC Question's Avatar
    I have a Galaxy S6 with Android version 6.0.1. The problem started about 2 months ago. The phone constantly switches between WiFi and 4G... You can see the little icons at the top of the screen blinking as the signals alternate.

    The constant switching makes my battery drain super fast. Can drain the whole phone in a couple hours. I also can't send pictures via SMS when the switching problem happens.

    Things I have done to try and fix the problem:
    1)clear partition cache
    2) turned off smart network switch
    3) Turned off Wifi and bluetooth scanning.
    4)Complete system factory reset.

    Thus far only the factory reset has helped - but it's a complete pain to do and then the problem comes back later....

    Does any one have the same issue or know of a solution?
    10-11-2016 10:04 AM
  2. belodion's Avatar
    Have you spoken to your carrier about it?

    Also, does it persist in Safe Mode?
    Burnrub likes this.
    10-11-2016 10:14 AM
  3. anon(632115)'s Avatar
    10-11-2016 10:31 AM
  4. Burnrub's Avatar
    Sorry for the Duplicate threads..

    I put the phone into safe mode and the problem appears to have stopped for now. does this mean I have an app that is casusing the switching issue or something else? Thanks for your help.
    10-11-2016 11:02 AM
  5. belodion's Avatar
    Sorry for the Duplicate threads..

    I put the phone into safe mode and the problem appears to have stopped for now. does this mean I have an app that is casusing the switching issue or something else? Thanks for your help.
    Welcome as a new member.

    Yes. Return to normal mode, then uninstall whichever app is causing the trouble. There lies the rub, of course: identifying the app....but it may help to start with whatever app you downloaded just before the trouble started.
    Clear Cache, Clear Data, and Force Stop before tapping Uninstall.
    Burnrub likes this.
    10-11-2016 11:55 AM
  6. Burnrub's Avatar
    You have been super helpful... I think i figured it out...

    I am currently using ATT as my carrier, but I had a Verizon messenger app on the phone (since that was my last carrier and I liked the functionality of the app.) The app has always worked fine when I sent texts, BUT i think when I've tried to send pics using the VZ messenger app, it somehow isn't compatible and caused the problem!
    belodion likes this.
    10-11-2016 12:24 PM

Similar Threads

  1. Galaxy S6: Black Screen and Flashing Green LED
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-18-2016, 04:23 AM
  2. Why is my phone rebooting and not charging when plugged in?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-11-2016, 12:49 PM
  3. how to delete cwm recovery from mi4 and get back to miui version
    By hatim pani in forum General Help and How To
    Replies: 1
    Last Post: 10-11-2016, 12:42 PM
  4. Replies: 2
    Last Post: 10-11-2016, 10:12 AM
  5. Replies: 1
    Last Post: 10-11-2016, 10:10 AM
LINK TO POST COPIED TO CLIPBOARD