1. AC Question's Avatar
    I recently replaced the battery to the htc one m8 and after I reassembled the whole thing, I get a flashing orange light at the top of the phone and a screen with a battery with a lightning bolt and 0% indicator.

    I wonder if I somehow fried the motherboard by unplugging things in the wrong order. Or perhaps I damaged a ribbon? This is disheartening... I tried putting the old battery back in the phone and reassembling, but it yields the exact same result (0% battery indicator).

    This kind of sucks.
    12-02-2016 05:00 PM
  2. thesilverbanger's Avatar
    The problem is the battery connector that is screwed in with two screws. Unscrew those and make sure the battery connector has snapped into place. If it's not, the phone will not know the battery is connected.
    12-02-2016 05:27 PM

Similar Threads

  1. V20 comfortable to hold and use?
    By jeffhuypham in forum LG V20
    Replies: 14
    Last Post: 12-03-2016, 04:46 PM
  2. Replies: 2
    Last Post: 12-02-2016, 10:57 PM
  3. Replies: 1
    Last Post: 12-02-2016, 10:51 PM
  4. My problem is It reads ,AP currently not in use.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-02-2016, 05:05 PM
  5. Voice commands and Google Play Music
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-02-2016, 04:35 PM
LINK TO POST COPIED TO CLIPBOARD