1. AC Question's Avatar
    Hi! Got a weird problem. Bought brand new Asus Zenpad 8.0, but it lags like hell- even in system settings menu you can see fps drop when the font is scrolling. is it normal for that kind of device or not? did all system updates, tried factory reset few times, everything is the same. havent rooted or modified yet. What do you think, is this just a crappy hardware or some software bug?

    Also, if i go To cpuz, cpux or any cpu detection related software, it shows that i have 4 cores 900mhz x86 cpu. It should be x64 and have a higher clock speed.
    12-17-2016 12:54 PM
  2. Rukbat's Avatar
    900MHz is very slow these days, but it's designed to run, if needed, at 1.4GHz. The bottleneck is probably the 1GB of RAM. It's 18 months old - and at the time it was released, it was a bit faster than most tablets, but it's considered slow these days.

    (BTW, "lag" is a very narrowly-defined word - it means "slow internet speed". That's not your problem, it's just a slow device.)

    (The Snapdragon 415 is an x64, but the detection software may only be differentiating between 86 and other CPU-types, and calling anything that's 86 "x86". An x64 processor is an 86-type device.)
    12-17-2016 03:49 PM

Similar Threads

  1. New Samsung browser
    By Roman Akert in forum Samsung Galaxy S7 edge
    Replies: 22
    Last Post: 01-07-2017, 08:43 AM
  2. Replies: 2
    Last Post: 12-18-2016, 02:27 AM
  3. New gboard question
    By Easton091 in forum Google Pixel & Pixel XL
    Replies: 6
    Last Post: 12-17-2016, 02:27 PM
  4. Video library not moving silently like S4
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-17-2016, 09:51 AM
LINK TO POST COPIED TO CLIPBOARD