1. AC Question's Avatar
    My phone was fine and yesterday I heard notification sound (of a text message or may be from game clash royal). It was placed on table a little away form me. It was working fine. I picked it up and pushed power button to see the screen and it was all dark time (kind of a like switched off).

    I have a normal charger, a turbo charger and a wireless charger. Mostly I use wireless charger but all work fine. I have been using them for months since I purchased this used driod turbo 2.

    Now it only switches on in fastboot mode when I use turbo charger and any option I select, i goes to Motorola start screen and that screen keeps blinking. It is just "Factory Mode" in that menu that starts up phone. Here, I see charging lightening icon on battery logo but when I use battary doctor or other battery app, it says battery is in discharging mode. So it is not charging. Now, all this happens when turbo charger is plugged in, but when I remove the charger, it switches off.

    Now, hours ago, it was saying battery at 56%. Then I put it on wireless charger a 1-2 hours and and 3-4 hours on normal charger. Now when I switched it on again with it says the battery is 76%. But everything else is the same. It switches off if I unplug the charger.

    Now, we don't have verizon or Motorola here. I purchased this phone from a guy few months back because I really liked it. Also, samsung phones are really expensive here. So, no support, it is all you and I.

    Do you have any idea what is wrong?

    This is my second Motorola phone that is cheating with me. I will never buy Motorola again!!!
    01-05-2017 08:34 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. You may need to consider reflashing the stock ROM. As for why there was an error, I am not sure.
    01-05-2017 09:46 AM
  3. EresDev's Avatar
    Welcome to the forums. You may need to consider reflashing the stock ROM. As for why there was an error, I am not sure.
    Thank you for your prompt response.

    I will need to put it in recovery mode to reflash the stock ROM, but it doesn't go there. As I have told you in the fastboot menu, if I select anything other than "Factory Mode", it comes to motorola start screen with its logo and that screen keeps blinking. So it does that in recovery mode and motorola screen keep blinking.

    In Factory mode, it starts up normally (without motorola screen blinking). So, I can't go to Recovery Mode and I can't reflash stock ROM.

    Also, when I connect my phone to PC with data cable, nothing happens. It doesn't power up, it doesn't start charging, and nothing happen in my PC.
    01-05-2017 10:28 AM
  4. Golfdriver97's Avatar
    Thank you for your prompt response.

    I will need to put it in recovery mode to reflash the stock ROM, but it doesn't go there. As I have told you in the fastboot menu, if I select anything other than "Factory Mode", it comes to motorola start screen with its logo and that screen keeps blinking. So it does that in recovery mode and motorola screen keep blinking.

    In Factory mode, it starts up normally (without motorola screen blinking). So, I can't go to Recovery Mode and I can't reflash stock ROM.

    Also, when I connect my phone to PC with data cable, nothing happens. It doesn't power up, it doesn't start charging, and nothing happen in my PC.
    Fastboot doesn't work like how the phone would when it's on. If you get fastboot set up, all you need to do in a command prompt is to enter fastboot devices, and the PC should give a response of showing the serial number.

    Check this out: How to install the Android SDK on Windows, Mac and Linux | Android Central
    01-06-2017 08:28 AM
  5. EresDev's Avatar
    Dear @GoldDriver97 I have not tried you suggestion but it got switched on. I opened it up and opened its battery. It stayed open because I was waiting for new battery to arrive and then replace it. But never battery didn't come and I closed it again. Now I put on the charger and it got switched on. The battery was already 78% when it got switched on. So battery was never an issue. It was something else.

    I am not sure how long it will keep working but I hope it will keep going. If it causes any problem, I will inform here. Thanks a lot.
    01-15-2017 01:47 PM

Similar Threads

  1. Replies: 1
    Last Post: 01-06-2017, 08:34 PM
  2. My Droid Turbo by Motorola stuck on No Command
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-06-2017, 08:11 AM
  3. S5 Won't Start After Factory Reboot
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-05-2017, 02:05 AM
  4. Replies: 0
    Last Post: 01-04-2017, 10:58 PM
  5. Is it bad to always use turbo charger?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-04-2017, 02:42 PM
LINK TO POST COPIED TO CLIPBOARD