1. AC Question's Avatar
    Hello, I have been using Miracast on my LG3 to connect to my tv via Screenbeam Pro dongle for over a month now with no problem. Just this week, it stopped working. Everytime I turn on Miracast, it searches for devices, the Screenbeam dongle shows up in found devices, I try to connect, on the tv screen it shows verifying security. On my phone, the screenbeam dongle disappears from the list of devices, and a few seconds later, on the tv it goes back to ready to connect.

    I've tried this with a D-Link receiver as well and get the same behaviour, shows up in listed devices, attempts to connect, I enter the pin from the tv, is checking security and the device vanishes from the list of devices. So this seems to be a problem with my LG3 and not the receivers.

    I haven't done anything to my phone, haven't installed anything new or any updates. Any idea how to fix this?

    Thanks
    02-01-2017 08:19 AM
  2. Daoudmbo's Avatar
    An update, I did a factory reset on my phone, an LG G3 (not LG3), but still the same problem. I will try with Screenbeam support and maybe Netflix support if they have any ideas. Miracast itself doesn't have any specific support?
    02-08-2017 07:50 AM
  3. French's Avatar
    Thanks for reporting back...I also have an update. I rolled back to an earlier version of the Netflix app...early December I believe...and I'm able to stream/cast to the Screen beam again. The version from January 24th that introduces saving to SD card seems to be where it got broken. The early December version includes the downloading feature but doesn't support SD card saving.

    Given this I believe it's a Netflix introduced problem. I attempted to email them and got a canned response linking me to a FAQ. I haven't had a chance to pursue further.
    Daoudmbo likes this.
    02-08-2017 08:07 AM
  4. Daoudmbo's Avatar
    Ok this sounds like the cause, it was around last January that it stopped working for me. How do I rollback the Netflix app? Or get an earlier one. Since I did a factory reset of the phone, I had to install all apps again, so It would have been the latest Netflix version.

    Thanks!
    02-08-2017 09:05 AM
  5. French's Avatar
    Search for apk mirror and within that search for Netflix. Interesting...I just did it myself to make sure I was telling you the right thing and now I see there are 2 more apks posted...one as recent as yesterday. So it's possible Netflix is working on this but I haven't had a chance to look into it and the t.v. that I use ScreenBeam on is at another location. I might be able to mess with it this afternoon and if I do I'll report back. But for now the version I have working is the December 9th one.

    ETA: Weird, the version on the Google Play Store is 4.13.0 build 14540 (January 24th), but this site has newer versions available. I'll try to spend some time playing with it this afternoon to see what transpires...

    Miracast stopped working on my LG3-screenshot-2017-02-08-10.54.41.png
    02-08-2017 09:57 AM
  6. Daoudmbo's Avatar
    Ok, I installed Netflix 4.12.2 from December and it works fine now! I won't update Netflix again until this bug has been fixed.

    Thanks!
    02-08-2017 12:37 PM
  7. French's Avatar
    I just tested and sadly the newer 2 posted are plagued with the same problem so the December 9th version 4.12.2 is the only one that will still cast.
    02-08-2017 02:00 PM
  8. French's Avatar
    I just talked to Netflix and they are acknowledging they are hearing of issues for some Android users since introducing the download to SD card feature. To be clear, they introduced downloading prior to the downloading to SD card...the December 9th version 4.12.2 is capable of downloading however it will only download to the internal phone storage (of which I have none left).

    Specifically, however, for the ScreenBeam, they are saying their system shows it is "not supported". I explained that it had been working just fine all the way up to the December 9th application and she was very nice and said she'd report it and that "you are right it doesn't make sense it would be supported prior and now it's not". I don't know if this will get anywhere or not and I REALLY hope it's just a bug and not by design, because if Netflix is purposely shutting down the ability to cast then other apps will likely follow suit. Comcast had it shut down from the beginning (jerks)...but Amazon still casts...I haven't tested HBO.

    Anyway I encourage you to call it in as well. Good luck.
    02-09-2017 09:18 AM

Similar Threads

  1. Samsung pay reseting on Gear S3
    By honda-Dave in forum Samsung Gear S3
    Replies: 7
    Last Post: 02-12-2017, 09:58 AM
  2. My screen is blank.
    By AC Question in forum Ask a Question
    Replies: 10
    Last Post: 02-04-2017, 06:44 PM
  3. Why is my Samsung screen taking me off things.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-01-2017, 11:16 AM
  4. Replies: 3
    Last Post: 02-01-2017, 10:56 AM
  5. Replies: 1
    Last Post: 02-01-2017, 08:23 AM
LINK TO POST COPIED TO CLIPBOARD