1. AC Question's Avatar
    Hi

    I just got the X96 box last month and set it up, watched one movie, and haven't used it in about a month. I moved the [same] TV it was connected to and tried to re-plug it in and nothing. Once or twice it blinked red once when plugged into a power source.

    it's not the remote batteries.
    it's not the power source.
    that was tested on multiple devices.

    I tried the factory reset where you take a toothpick and press the reset button in the AV socket, and then plug in power and nothing happened.

    what's wrong with it? it's brand new!!!
    04-02-2017 10:09 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! These kinds of Android TV boxes are more prone to failure, since quality control is not likely to be very high. Is it still under warranty? Contact the manufacturer.
    04-03-2017 10:20 PM

Similar Threads

  1. Replies: 1
    Last Post: 04-03-2017, 10:27 PM
  2. Bettery not changing full when poweron
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-03-2017, 10:20 PM
  3. Text on S8 not going Edge-to-Edge anymore like the S7?
    By donm527 in forum Samsung Galaxy S8 & S8+
    Replies: 11
    Last Post: 04-03-2017, 04:09 PM
  4. Why do apps take forever to download on my new s6?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-03-2017, 02:24 AM
  5. New S7 update has made the Always On Screen LESS useful!
    By mike21b in forum Samsung Galaxy S7
    Replies: 5
    Last Post: 04-02-2017, 11:41 PM
LINK TO POST COPIED TO CLIPBOARD