1. Ashishkolwar's Avatar
    I have faced this situation before also. I've run the hardware test and my both front and rear camera and flash LED failed in the test. I've tried restarting but nothing happened but after 2-3 days my camera gets back and working fine don't know how but after 3 weeks around this problem returned and now I have tried to clear data of camera app and gallery app, tried restarting my phone, tried wiping cache of phone in the recovery mode and even tried clearing user data from recovery mode of my smartphone but nothing works now. If it is a hardware failure camera at the first time wouldn't have come back.
    Please help!!!
    04-21-2017 08:18 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does it work in Safe Mode? How to turn on safe mode on Xiaomi Mi 4i. If not, then it's either a hardware or firmware issue. I don't see why it couldn't be a hardware failure -- perhaps there was a connection that has been tenuous and starting to fail, but it stabilized for a few days before finally failing completely.
    04-21-2017 06:50 PM

Similar Threads

  1. Pixel and the lack of 3xCA support
    By kolyan2k in forum Google Pixel & Pixel XL
    Replies: 21
    Last Post: 04-23-2017, 11:47 AM
  2. Replies: 1
    Last Post: 04-21-2017, 06:56 PM
  3. Replies: 1
    Last Post: 04-21-2017, 08:55 AM
  4. Verizon Galaxy S8 Definitely step up from my S7Edge
    By shantheman73 in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 04-21-2017, 08:30 AM
  5. Replies: 1
    Last Post: 04-21-2017, 08:12 AM
LINK TO POST COPIED TO CLIPBOARD