1. bmcdee123's Avatar
    Since upgrading to JB, has anyone else had severe responsiveness issues with Chrome or Stock Browser? Both for me are now taking forever to load, sometimes not loading at all. Scrolling is sometimes completely unresponsive, while at others it is ultra fast like I would hope.

    Anyone else having this issue? Unfortunately I never had these problems in ICS, or I would say it's just an issue with my tablet.
    10-01-2012 10:11 AM
  2. Cobravision's Avatar
    Between my Epic 4G Touch's ICS update and the JB update for the TP, I am starting to get the feeling that the longer you use your device, the more you need to perform a factory reset. My E4GT was only a couple of months old due to it being a TEP replacement (but new out of the box). My TP, OTOH, has been used heavily since January. The ICS update went smothly on the E4GT, but the JB update did not make the tablet that much better. After the factory reset, everything starting working very fast. Even swiping the lock screen is much faster -- it got so slow on ICS that I disabled it altogether.

    Which another way of saying Chrome is still fine after JB and factory reset. Dolphin is crazy fast now.
    10-01-2012 10:43 AM
  3. Treknologist's Avatar
    I've not had browser issues either. I have, in fact, been pleasantly surprised at how quick Dolphin is on JB! Both Chrome and the stock browser have also been performing properly. The only one I haven't tested yet is Firefox.
    10-01-2012 05:36 PM
  4. enthuz's Avatar
    That is my experience also. I am amazed at the speed improvements.
    10-01-2012 06:18 PM
  5. swyost's Avatar
    Unfortunately, the short answer from me is definitely yes. Both seem to hang at times and if I switch between the stock email and the browser, the screen will go black for a few seconds. Periodically, I have also found that the address bar will be partially hidden - neither completely visible nor completely concealed. In addition, I have found that there is a much longer delay with either the app or OS locked before the Force Close message appears. I have added these to a growing list of other problems such as Vevo crashing at random; OfficeSuite 6+ crashing when trying to load large, complex, documents; and a pharmacy app not recognizing my password but if I paste the same password in their website it logs on. From my perspective, it is another Android upgrade that is not ready for prime time. People seem to give Google far too much slack when it comes to this stuff....
    10-01-2012 06:44 PM
  6. Va1ha11a's Avatar
    Actually, my browsing expieriance has vastly improved since the JB update. Before it would constantly lag and often fc, but now, smooth as butter (than again, this may be due to my finally squashing the chrome desktop bug where bookmarks duplicate out of control, and rename themselves to "Encrypted". I have ~100 bookmarks, but when I finally noticed the issue, I was at 38,545! Loading all those is probably what caused chrome to constantly crash)
    10-01-2012 07:16 PM
  7. Devinator's Avatar
    Actually, my browsing expieriance has vastly improved since the JB update. Before it would constantly lag and often fc, but now, smooth as butter
    This has been my experience as well. I no longer receive hangups in my browser.

    As for others, do you clean the cache for your browsers (both through manage apps and through settings) periodically. That could account for things getting slower over time.
    10-02-2012 09:51 AM
  8. ba4g's Avatar
    I think this stuff all boils down to who is selling a device with Android. ASUS seems to be a little complacent in their attention to detail. By contrast my HTC phone rocks everything I ask it. I am thus far pleased with Jelly bean, but its not iPad quality, but man is it easier to do things with.
    10-03-2012 11:52 PM
  9. Va1ha11a's Avatar
    On the other hand, my htc evo 4g lte came out three months ago, my asus transformer prime came out nine months ago, guess which go jelly bean first?
    10-04-2012 04:23 PM
  10. Kevin OQuinn's Avatar
    Chrome is sslllooowwww for me. Firefox is much faster and smoother. Nope, I didn't do a factory reset after the update. Maybe I should.
    10-04-2012 06:26 PM
  11. Devinator's Avatar
    Really? Chrome runs slow for you? I just installed it the other day to test it and it seems to run well. The only thing holding me back is I like the thumb controls in the stock browser, so awesome.

    If I have time, I'll have to install FF to see if I like it. Had it about a year ago and I ditched it because I didn't see any reason to have it over the stock browser at the time.
    10-05-2012 10:30 AM
  12. Kevin OQuinn's Avatar
    Really Chrome runs slow for you? I just installed it the other day to test it and it seems to run well. The only thing holding me back is I like the thumb controls in the stock browser, so awesome.

    If I have time, I'll have to install FF to see if I like it. Had it about a year ago and I ditched it because I didn't see any reason to have it over the stock browser at the time.
    Yeah it does. I just did a factory reset so we'll see if that helps.
    10-05-2012 11:23 AM
  13. Va1ha11a's Avatar
    Check the number of bookmarks you have and try reinstalling chrome. I did that and speed improved vastly
    10-06-2012 03:45 PM

Similar Threads

  1. 4G and web browsing issue
    By BigAinCA in forum HTC EVO 4G
    Replies: 3
    Last Post: 08-10-2010, 09:04 PM
  2. Web Browsing History - Shared?
    By volcom.airsoft in forum General Help and How To
    Replies: 1
    Last Post: 08-10-2010, 07:05 PM
  3. Replies: 2
    Last Post: 08-03-2010, 08:47 PM
  4. Replies: 10
    Last Post: 06-18-2010, 03:36 AM
  5. erratic browsing experience at times
    By drudometkin in forum Motorola Droid
    Replies: 5
    Last Post: 11-16-2009, 02:05 PM
LINK TO POST COPIED TO CLIPBOARD