Ive tried google and forum searches, and only find things related to rooting/booting from SD Card. I've already rooted it and whatnot. The issue is that I insert my SD Card, and it immidiately shows the "It is now safe to remove your SD Card" message, and never actually mounds the card.

I've formatted it on Windows 7 and I get the same error message. I've formatted it 'internally' (even though it isn't mounted, it offers to format my card for me.) I get an error message that the 'Activity SD Card' application has locked up, and I can 'Wait' or 'Force Close.' It immediately then mounts my formatted SD card, but this is insane. Any time I remove the SD card to put new files on it, I have to go through this process and back the entire card up to my hard drive. What should take just a couple of minutes takes at least twice as long. It also occasionally wakes up from sleep mode with a corrupted SD Card that I have to format.

This is a different card than I used to root it with (Since I used a 2GB 'root file' on a 4GB SD Card, and could never figure out how to fix it, I tossed that one.) it's a fresh micro SD card used only for the Nook Color. What is going on?