Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  
    LDel's Avatar

    Posts
    1 Posts

    Angry Galaxy Prevail Just Stopped Working, only 2 months old????

    I have a Galaxy Prevail and just purchased it less than 2 months ago. Everything was working perfectly and all of a sudden yesterday it just went off and never came back on.

    At first I just thought that it was in sleep mode, so I pressed the power button, expecting it to light up, but nothing happened. The last time I looked at it, it was charged more than halfway, so I wasn't sure why it would have died out so quickly, so I tried charging it for about 2 hours and it still wouldn't turn on. This is the first time it has happened. I took the battery out, waited a few minutes and still, nothing is happening. I have charged it overnight and still nothing this morning.

    The phone is only 2 months old, something is very wrong for it just to quit working like this. Please help!
  2. #2  
    sblood86's Avatar

    Posts
    431 Posts
    ROM
    Quatrimus / CM10

    Default Re: Galaxy Prevail Just Stopped Working, only 2 months old????

    Quote Originally Posted by LDel View Post
    I have a Galaxy Prevail and just purchased it less than 2 months ago. Everything was working perfectly and all of a sudden yesterday it just went off and never came back on.

    At first I just thought that it was in sleep mode, so I pressed the power button, expecting it to light up, but nothing happened. The last time I looked at it, it was charged more than halfway, so I wasn't sure why it would have died out so quickly, so I tried charging it for about 2 hours and it still wouldn't turn on. This is the first time it has happened. I took the battery out, waited a few minutes and still, nothing is happening. I have charged it overnight and still nothing this morning.

    The phone is only 2 months old, something is very wrong for it just to quit working like this. Please help!
    Well unfortunately I expect it's going to require a replacement you could at least first see if you have access to emergency mode. Friend of mine has a prevail and there is a stock odin backup you could attempt to install from emergency mode if it will boot to their, I can't remember where he found the odin backup though, definitely a different forum.

    before you go out looking for the backup though try booting it to emergency mode first, should be hold down camera+volume down+and power until you see a samsung screen, if you do see a samsung screen it should boot into emergency mode no problem, if not sadly I think it's fubard. I find the prevail to be interesting for what it is they put way more of a cpu in it than really needed and it gets hot fast; my friend keeps his underclocked at 480 without performance issues, vs I want to say it runs at 800 by default. Than again I'm in Texas so heat is on my mind a lot with electronics that may not be related to your issue.

    Good luck, sorry to hear about your device and the slow response.
  3. #3  
    rcdd's Avatar

    Posts
    1 Posts
    Global Posts
    2 Global Posts

    Default Re: Galaxy Prevail Just Stopped Working, only 2 months old????

    android forums dot com......
  4. #4  

    Default Re: Galaxy Prevail Just Stopped Working, only 2 months old????

    Aargh. Same sorta thing just happened to me. Did you find a solution?
  5. #5  

    Default galaxy prevail

    The same exact thing happened to me my phone galaxy prevail (boost) has been working perfectly fine i only have had it for over a month and it was in sleep mode this morning i clicked the power bottom to turn the screen on to check my phone and it froze up with the back arrow and other button lit up then it stayed stuck like that for 15mins i then took out the battery and tried to turn it back on and the samsung logo comes out but then it doesnt load or turn on , just the screen is black with the back light on, i dont get it i didnt do anything to the phone and its fairly new!! this is bs i dont have insurance on it and i dont understand why it just failed on me!!! can anyone suggest trying anything? p.s im over andriods

Posting Permissions

B