Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Unhappy battery icon flashes but won't charge

    I have a Samsung Prevail from Boost Mobile. It worked fine until last night. Battery died while it was in my bag. Plugged it in to charge. At first, nothing. Then the battery icon appeared. Appeared, disappeared - been flashing on and off like that ever since without charging at all. I can't turn it on to reset it. Tried to reset it by holding down camera/volume/power keys. As soon as the Samsung splash screen showed it was replaced by a black screen with the word "downloading . . . " in green. This also flashed on and off until I let go of the buttons. Phone still won't charge - same flashing on and off of the battery icon. Thoughts? Suggestions? Fixes? Darn thing is only 4 months old. Feeling frustrated.
    Thanks so much, Lisa
  2. #2  

    Default Re: battery icon flashes but won't charge

    Code:
    I'm having the same problem with my prevail as of last night. Did you ever figure out what caused the problem and how to fix it????
  3. #3  
    Golfdriver97's Avatar

    Posts
    25,753 Posts
    Global Posts
    26,196 Global Posts
    ROM
    Stock

    Default Re: battery icon flashes but won't charge

    Is the entire problem the same?

    From an AOSP M8.
    ‚Äč
    What could not be changed, must be endured - New Spring, by Robert Jordan

    Community Guidelines and also here, Developer Rules, and Marketplace
    Mobile Nations Sister Forums: iMore/Connectedly/Windows Central/Crackberry

Posting Permissions