Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  
    jebb's Avatar

    Posts
    15 Posts
    Global Posts
    44 Global Posts

    Angry Wi-Fi turning on automatically - what am I missing?

    This is currently the biggest gripe I have with my stock/non-rooted ICS 4.04 RAZR MAXX HD and I can't seem to get to the bottom of it. Something is automatically enabling the wi-fi. It seems to happen at random. It does it while I'm sleeping and the device hasn't physically moved anywhere (but some nights it's fine), randomly during the day, and it seems to commonly happen when I drive and show up at a new location (work, etc). This would lead me to believe it's one of the Smart Actions or Google location services. But I've turned that stuff off.

    I have the following disabled and Wi-Fi is still enabling itself:

    Settings->Wi-Fi->Auto-Connect Wi-Fi
    Settings->Wi-Fi->Advanced Wi-Fi->Keep Wi-Fi on during sleep
    Settings->Location services->Google location services
    Settings->Location services->Location & Google search
    Settings->Location services->Standalone GPS services
    Smart actions - all location-based triggers
    Smart actions->Settings->Motorola Location Services
    Maps->Settings->Location sharing (Latitude)
    Play Store->Settings->Google AdMob Ads
    Facebook->Settings->Messenger location services
    Facebook->Settings->Refresh interval->1 hour
    Evernote->Settings->Sync Notes->Sync automatically->Every 1 day
    Evernote->Settings->Other Options->Use GPS Satellites
  2. #2  

    Default Re: Wi-Fi turning on automatically - what am I missing?

    There is only one thing I can see that I have unchecked that is not in your list. At the top of the list of wi-fi settings is "Notify me blah blah blah" I have this unchecked and I do not get the wi-fi prompts. Have you tried a reboot after changing the settings?

    I use the location services and some smart actions, so I don't think they are your problem.
    No matter how hard you push the envelope, it will always be stationery...
  3. Thread Author  Thread Author    #3  
    jebb's Avatar

    Posts
    15 Posts
    Global Posts
    44 Global Posts

    Default Re: Wi-Fi turning on automatically - what am I missing?

    Quote Originally Posted by Maddog241 View Post
    There is only one thing I can see that I have unchecked that is not in your list. At the top of the list of wi-fi settings is "Notify me blah blah blah" I have this unchecked and I do not get the wi-fi prompts. Have you tried a reboot after changing the settings?

    I use the location services and some smart actions, so I don't think they are your problem.
    I forget to list that one - yes, it has been unchecked for some time. I have done several reboots.When I got up this morning Wi-Fi was on again. I looked at the battery usage stats and it appears to have turned on shortly after midnight. I then disabled it, and a literally few minutes later I see it come on again (screen was still on, still using the phone-I think I was in Taptalk). Just to be sure all my settings had taken affect, I did a reboot prior to leaving for work. So I reboot, don't open a single app, pull into work and bam, Wi-Fi is on AGAIN.

    The only smart action I have enabled is a sleep rule. (Triggers: Timeframe, Actions: Ringer volume, VIP caller mode, & Brightness)
  4. #4  

    Default Re: Wi-Fi turning on automatically - what am I missing?

    I had issues when I used the built in "sleep rule". What I did for my nighttime smart action was create one from scratch. Beyond that, the only other thing I can think of is possibly an app causing the problem. In the app settings you can see all that are running. They can be running and affecting things and not be "opened" by you. You might want to try to stop some of the ones you added one at a time and see if you can narrow it down.

    Another less attractive option would be FDR. Sometimes a lot of work, but sometimes the only way to eliminate problems that can't be identified.
    No matter how hard you push the envelope, it will always be stationery...
  5. Thread Author  Thread Author    #5  
    jebb's Avatar

    Posts
    15 Posts
    Global Posts
    44 Global Posts

    Default Re: Wi-Fi turning on automatically - what am I missing?

    I am working on narrowing down my apps - the only one I see right away is Skype - it has the ability to toggle the wi-fi state, according the app list. I force closed it, cleared its data, and uninstalled it but that didn't do the trick.

    I just deleted and recreated my sleep rule from scratch to and performed a reboot. Wi-Fi enabled again itself within 10 minutes. Wiping the device is sounding more appealing the more time I spend on it without results. Thanks for your continued support and suggestions.
  6. #6  

    Default Re: Wi-Fi turning on automatically - what am I missing?

    Have you looked at the apps that are actually running? That list might help you narrow it down. As much of a pain as FDR is, it might be the only way to eliminate the problem. If you do that, I would suggest unchecking Notify Me and Auto connect Wi-fi before you restore anything. Those are the only 2 I have unchecked from your original list. Then, only restore one app at a time and see if/when the problem returns.
    No matter how hard you push the envelope, it will always be stationery...
    Thanked by:
  7. Thread Author  Thread Author    #7  
    jebb's Avatar

    Posts
    15 Posts
    Global Posts
    44 Global Posts

    Default Re: Wi-Fi turning on automatically - what am I missing?

    Found the culprit - MobileIron app.
    Thanked by:
  8. #8  

    Default Re: Wi-Fi turning on automatically - what am I missing?

    Quote Originally Posted by LN2 View Post
    Found the culprit - MobileIron app.
    Excellent! Glad to hear that. Now I bet you battery life will improve some as well.
    No matter how hard you push the envelope, it will always be stationery...
  9. #9  

    Default Re: Wi-Fi turning on automatically - what am I missing?

    Glad to hear you fixed the problem. I didn't have the problem but I was following this thread cuz I might learn something.

    Just out of curiosity I looked up Mobileiron. In the discription was a little note that said, "automated access to corporate wifi and VPN networks."

    I learned that when checking out apps I may want to install on my phone, I should read everything in the description section. For that I thank both Maddog and LN2.

    Now I'm patiently waiting for my next smartphone (I have the Maxx HD) to be released sometime in the summer of 2014!
    dirkbonn
    The government can't give you anything until it first takes it from someone else.
  10. Thread Author  Thread Author    #10  
    jebb's Avatar

    Posts
    15 Posts
    Global Posts
    44 Global Posts

    Default Re: Wi-Fi turning on automatically - what am I missing?

    This is what made me suspicious - if you navigate to Settings->Apps and view the downloaded list, select the app, scroll down to "permissions", and under "System tools" it reads "change Wi-Fi state".

    MobileIron can automatically populate Wi-Fi settings with SSIDs and passwords provided by your employer, hence the "automated access to corporate wifi and VPN networks." The ability to enable Wi-Fi might be for location related features. Regardless, the developer has been contacted. Hopefully they fix the bug soon.

Similar Threads

  1. Wi-Fi turning on randomly.
    By kawana72 in forum Droid RAZR MAXX
    Replies: 4
    Last Post: 05-08-2013, 03:54 PM
  2. Wi-Fi turns on by itself AFTER i turn it off
    By iceberg384 in forum Verizon Galaxy S3
    Replies: 1
    Last Post: 11-14-2012, 07:55 PM
  3. Wi-fi turns itself on
    By JRodHimself in forum Sprint Galaxy S3
    Replies: 2
    Last Post: 11-13-2012, 03:00 PM
  4. Replies: 1
    Last Post: 07-08-2010, 07:10 PM
  5. wi fi turning off and back on
    By scotth45 in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 06-08-2010, 07:44 PM

Posting Permissions

B