Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 27
Like Tree5Likes
  1. Thread Author  Thread Author    #1  

    Default [Solved] Disable Facebook Birthday Notifications

    I keep getting notifications in the notification bar from facebook (apparently) telling me when people have birthdays. I can't figure out why I am getting these. I have disabled notifications from the facebook app. I am not syncing facebook contacts with my phone. To the best of my knowledge, these things shouldn't be showing up, but they are.

    Is anyone else having this issue? Does anyone have a solution to make them stop? (Other than the obvious solution of deleting the facebook app?)

    I've searched and have not found any solutions. I'm starting to wonder if this is just one of those "have to live with it" things. Grumble.

    *** UPDATE 21 DECEMBER 2012 ***

    Thanks to everyone for the suggestions. As best I can tell, even when you turn off all notifications from within the facebook app [ Facebook --> Settings --> Notifications ], the current version will ignore the setting in the case of birthday notifications.

    The only solution that worked for me was to turn off all notifications for this app through the Android app manager itself [ Settings --> Apps --> Facebook --> Show notifications ]. But that worked like a charm.

    *** UPDATE 01 JANUARY 2013 ***

    It appears that maylouwho12 has found the correct setting buried in the facebook account settings. See reply #12 in this thread for details. Thank you, marylouwho12!
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
    Thanked by:
    Stig Nygaard likes this.
  2. #2  
    t0ked's Avatar

    Posts
    169 Posts
    Global Posts
    187 Global Posts

    Default Re: Disable Facebook Birthday Notifications?

    In calendar app, goto settings then calendars to display and uncheck the facebook calendar. if thats not there, one of the calendars there may have synced all your fb info.
  3. Thread Author  Thread Author    #3  

    Default Re: Disable Facebook Birthday Notifications?

    Quote Originally Posted by t0ked View Post
    In calendar app, goto settings then calendars to display and uncheck the facebook calendar. if thats not there, one of the calendars there may have synced all your fb info.
    Thanks for the suggestion. The only calendars there are (A) my gmail account calendar; and (B) my device calendar. When I view the calendars, they don't seem to have these birthdays listed. I will uncheck the "Device calendar" to see if that helps.

    Is it relevant at all that the icon in the notification bar is a small facebook icon? I guess I would have assumed that had to be generated from the facebook app.
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  4. #4  

    Default Re: Disable Facebook Birthday Notifications?

    Go into your app list > Settings > Accounts & sync > select your Facebook account > uncheck the Sync Contacts.
    Current: Moto X (2014) Pure Edition, ASUS ZenWatch, Pebble Steel, Chromecast
    Retired Device (in order): HTC One (M8), Samsung Galaxy S4, Droid Razr Maxx, HTC Thunderbolt, HTC myTouch 4G, Blackberry's Bold, 8900 (Curve)

    Jerry: "Love, Peace, and Chicken Grease!!!"
  5. Thread Author  Thread Author    #5  

    Default Re: Disable Facebook Birthday Notifications?

    Quote Originally Posted by fatboy97 View Post
    Go into your app list > Settings > Accounts & sync > select your Facebook account > uncheck the Sync Contacts.
    I double checked that, indeed, Sync Contacts is off. I actually don't see a menu specified "exactly" as spelled out above, but I'm sure it's the same one. Settings --> Accounts --> Facebook --> Contacts is where I go, and it's not really a checkbox, but rather a "toggle" to enable or disable sync. In any case, it's off.

    If it helps at all, it really does look like it is coming from the Facebook app itself. When the icon appears in the Notification Bar and I swipe down to see all of the notifications, the app identifies itself as Facebook. And if I long-press the notification itself, I get a link to "App info" that verifies it is coming from the Facebook app.
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  6. #6  
    Who?'s Avatar

    Posts
    391 Posts
    Global Posts
    400 Global Posts

    Default Re: Disable Facebook Birthday Notifications?

    So then turn off Facebook notifications from the Facebook app.
    Thanked by:
  7. Thread Author  Thread Author    #7  

    Default Re: Disable Facebook Birthday Notifications?

    Ah-HA! Maybe I have found it. As I mentioned above, when I long-click on the notification, I get a link to "App info". When I press that, it takes me to the regular app page where I can select Force Stop, Uninstall, Clear Data, etc.

    There is actually a check box there that says "Show notifications". I will try unchecking that to see if it does the trick. Still surprises since I turned off notification within the Facebook in-app Settings panel, but oh well. Hoping this does the trick. Will report back in a day or two when I know if it is working or not.
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  8. Thread Author  Thread Author    #8  

    Default Re: Disable Facebook Birthday Notifications?

    Quote Originally Posted by whatwhat View Post
    So then turn off Facebook notifications from the Facebook app.
    Oops! Missed your answer. :-) Never saw that before... will give it a go. Thanks!
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
    Who? likes this.
  9. #9  
    Who?'s Avatar

    Posts
    391 Posts
    Global Posts
    400 Global Posts

    Default Re: Disable Facebook Birthday Notifications?

    No worries, there's a serious over-quoting problem in these forums so I can understand why you'd miss my post. Good luck!
  10. Thread Author  Thread Author    #10  

    Default Re: Disable Facebook Birthday Notifications?

    Thanks to everyone for the suggestions. As best I can tell, even when you turn off all notifications from within the facebook app [ Facebook --> Settings --> Notifications ], the current version will ignore the setting in the case of birthday notifications.

    The only solution that worked for me was to turn off all notifications for this app through the Android app manager itself [ Settings --> Apps --> Facebook --> Show notifications ]. But that worked like a charm.
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  11. #11  

    Default Re: Disable Facebook Birthday Notifications?

    I think I have a solution. This is for the Galaxy S3 but it might work for you.

    Tap the button with the button with the 3 lines on the top left of the Facebook app. scroll down to the bottom and tap account settings. It will ask you to Login to a device app if you haven't already. Then tap notifications and uncheck the birthday reminder box. I Hope this helps. I'm not sure why Facebook is making this so difficult.


    Magic Tech Pros, LLC
    magictechpros.com
  12. #12  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Absolutely none of this worked for me (I have a Samsung Galaxy S3). I went to the Facebook app, clicked on the button with three bars at the top left, went to Account, then Account Settings, then Notifications, then Mobile Push and unchecked Birthday Reminder. So:

    1. Facebook app.
    2. Button with three bars at top left.
    3. Account.
    4. Account Settings.
    5. Notifications.
    6. Mobile Push.
    7. Uncheck Birthday Reminder.

    Hope this helps!
  13. Thread Author  Thread Author    #13  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Wow.... that was buried in the depths of obscurity. Thanks for finding and posting that! That seems to be the "correct" solution for this, and I don't think I would have ever found it on my own. Will update original post at top to point folks to your response. Thanks!
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  14. #14  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    I don't have a birthday notification option under push, now what? HELP
  15. Thread Author  Thread Author    #15  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Are you on a Droid Razr HD or Droid Razr Maxx HD? With the latest version of Android and the facebook app? Just checked mine again, and indeed I have the setting available. If you have a different phone or different version of Android, it may be in a different place. No doubt that the setting was buried and hard to find.
    Droid RAZR MAXX HD ( Current ROM = Stock )
    http://www.pmkelly.com/
  16. #16  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    I have a Droid Razr Maxx and this setting is not there. My issue is slightly different - I am NOT getting birthday reminders and would like to get them . I have been digging through every menu I can find and have not found it yet.
  17. #17  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Thanks a million for solution #12 - worked for my Android Samsung Galaxy Note II!
  18. #18  
    joe_fresh's Avatar

    Posts
    418 Posts
    Global Posts
    1,509 Global Posts
    ROM
    HTC One stock

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Just got my first one today. Worked like a charm
  19. #19  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Awesome. Exactly what I was looking for and gave me a chance to use multi Window apps for an good reason
  20. #20  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Hi guys. Something strange happened to me regarding these birthday FB notifications. You see, I have not ever recived these kind of notifications until today. I received something like "Celerate with Mary' today. Write a birthday wish on her timeline". So, how this was generated. Anyone with the same kind of notification?
  21. #21  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    I thought I would go crazy trying to get rid of the birthdays in my new Galaxy S4. I did everything everyone said and FINALLY (at least on the S4) tap your small calendar, open settings, go to calendars (this will not appear unless you have the calendar open), tap display then make sure that Facebook and contact's birthdays are not checked. Then hit done at the top and they magically disappear. YAY!!!
  22. #22  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Can you tell me how the birthdays on these notifications are chosen? I cant figure it out! I know them all, but there are others I would like to recieve, I dont know how! Can help? (Dont want the calendar sync alternate method, whant this through native android app...)
  23. #23  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    I have a Galaxy Note 3 and you are the bomb... this WAS frustrating, thanks so much.
  24. #24  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Thank you Edie Kilchenstein - this problem was driving me nuts - birthdays now gone from my calendar - brilliant!
  25. #25  

    Default Re: [Solved] Disable Facebook Birthday Notifications?

    Thank you so much. I have been trying to delete the FB birthdays from my calendar for a week and this finally worked!!
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 8
    Last Post: 09-26-2014, 04:57 PM
  2. Can you share AutoAwesome GIFs on Facebook?
    By chrismage in forum Google Nexus 5
    Replies: 2
    Last Post: 09-19-2014, 05:30 PM
  3. Replies: 1
    Last Post: 09-19-2014, 02:44 PM
  4. how to solve this problem
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-19-2014, 03:14 AM
  5. Replies: 1
    Last Post: 09-18-2014, 10:28 PM

Posting Permissions