1. AC Question's Avatar
    Does anyone know how to disable the proximity sensor on a razr maxx hd. My screen goes black as soon as I make a call, nothing I do will turn the screen back on. I have no dial pad, cant turn on speaker phone, have to wait for other party to hang up before screen will come back on. Seems like if I could disable the proximity sensor that may fix it. Any ideas??
    06-18-2014 07:31 PM
  2. Almeuit's Avatar
    Check under the call settings within the settings menu of the phone to see if this is an option.

    Sent from my T-Mobile Note 3 using AC Forums.
    06-18-2014 11:56 PM
  3. phamdd's Avatar
    Hi

    I had the same issue recently, it seems the proximity sensor doesn't work properly and it always see there is something near the phone. During the phone call, this will automatically turn off the screen.

    I work around this using the app named "Proximity Screen Off Lite" https://play.google.com/store/apps/d...4ucz.screenoff

    I configure the app as below.

    1. Screen On/Off Modes
    Check "Cover and hold to turn on Screen"
    Timeout: 1 second
    Check "Disable Accidentla Lock"
    Timeout: 4 seconds

    2. All settings
    Check "Disable in Lanscape"
    Check "Lock phone on screen ON"

    3. [Advanced] Configure Sensore
    Select sensor: Proximity sensor
    Value when sensor covered: 0
    Value when sensor un-covered: 1

    Turn on the service and enjoy your phone calls.

    Hope it help.
    Gryphon SK and linsalata28 like this.
    06-19-2014 01:04 AM
  4. Simil Khan's Avatar
    Thanks a lot... Phamdd
    07-13-2014 01:51 AM
  5. Mike Clarke2's Avatar
    Solution: Guys been reading everything nothing works even the solution apps given. Best thing I found was opening the phone up wrapping a tiny bit of tin foil over the sensors (the shiney side) to reflect the light back in on itself, no more issues. Side effect is you have to manually turn the screen off with the power button in convo, small price considering I had a black screen before. Hope that helps.
    lukemartin87 likes this.
    04-06-2015 03:56 PM
  6. kaefert's Avatar
    I had the same problem, that the proximity sensor stopped working.

    The solution that worked for me was to install the app com.hatcyl.android.Hardware_Disabler (sadly not in the playstore (anymore?))
    Found it by googling it - correct size=99105bytes md5sum=cfdf0eaec8c259a8c43ce3cfcb3771f2

    Got the hint from a comment from the stackoverflow question id=24982571 name="disable-proximity-sensor-during-call" (I'm not allowed to post links here, since this is my first post)

    For my Sony Xperia Z (with pacman rom 4.4) I simply needed to disable the device "/sys/bus/i2c/drivers/apds9702" and now I can use my phone while in a call again
    04-19-2015 04:16 AM
  7. Gryphon SK's Avatar
    EDIT: This only worked for one or two calls, then the issue returned.
    04-25-2015 12:32 AM
  8. dgrobe2112's Avatar
    How do I get the notification off the screen
    06-19-2015 12:42 PM
  9. Rahul Singh41's Avatar
    thanks for suggestion. and now i can recived my call. but when i dial a number. the problem start again and my screen light is off.. plz reply
    06-22-2015 07:17 AM
  10. XESHAN16's Avatar
    Hey I tried it on my lg optimus e970 but all in vain. The screen still does not turn on when I remove phone from ear
    07-24-2015 01:40 AM
  11. Jozef Kutka's Avatar
    hello, also thanx, it helps cause i have broken proximity sensor.
    but i need to set it like always uncovered
    can you help me how? cause i have tried previous setting but there are still unstable things during calls
    thx
    08-03-2015 07:15 AM
  12. Larson Pinto's Avatar
    This is how I fixed the issue. Go to Phone App, Three Dots in a vertical line button, Settings or call settings, disable proximity sensor. Now phone will remain on at all times so you can use the numpad and anything else you need.
    09-21-2015 09:52 AM
  13. Mudassir Mudassir iqbal's Avatar
    I have G2 LG Problam is a light sensor .on Day light cell prefact worked.but night time sensore are not work i click tha ON buttan Display not stay going back Off and Other activets is 100% working but problam have display Go back OFF Plz Help
    10-19-2015 11:59 AM
  14. Mudassir Mudassir iqbal's Avatar
    I have G2 LG Problam is a light sensor .on Day light cell prefact worked.but night time sensore are not work i click tha ON buttan Display not stay going back Off and Other activets is 100% working but problam have display Go back OFF Plz Help
    10-19-2015 12:02 PM
  15. alizafarshah's Avatar
    Thanks.

    Works for me when I use the light sensor instead of proximity sensor in the settings.

    Working so far!
    11-07-2015 10:00 AM
  16. Marktmover Webmaster's Avatar
    The answer for me was to keep my hand away from the top of the phone. If I wanted to hit the speaker button, I would sneak my finger up from the bottom side of the phone. SFT is way too sensitive, and needs some control panel options.
    04-26-2016 12:48 PM
  17. lukemartin87's Avatar
    This worked for me thanks!! I just replaced the screen on my Moto G and had problems with this. Cheap knock off screen didn't work as good. I tried tightening screws and installing disabling apps and re calibration aps. Nothing worked except for this. I think the problem was the sensors weren't close enough to the new screen holes for them. THANKSSSSS!!!!!!!!!!!!!!!

    Put a piece of tin foil over the sensor and problem solved.
    12-20-2016 05:49 PM

Similar Threads

  1. Replies: 4
    Last Post: 06-01-2016, 04:45 PM
  2. Note 3 - Notification Sounds permanently disabled
    By SysopChris in forum Ask a Question
    Replies: 2
    Last Post: 06-26-2014, 11:26 AM
  3. Replies: 4
    Last Post: 06-18-2014, 12:03 AM
  4. Disable App Updates Except on Wifi in KitKat?
    By ClaudiaP in forum Verizon Galaxy Note 2
    Replies: 3
    Last Post: 06-16-2014, 12:12 PM
  5. How to disable AT&T check while starting FoxFi WiFi
    By chandantalukdar in forum AT&T Galaxy S III
    Replies: 1
    Last Post: 06-15-2014, 06:37 PM
LINK TO POST COPIED TO CLIPBOARD