1. d.meyer's Avatar
    I need an app that blocks my number when I text(work purposes) when I select the block option on my settings my number still the appears.. Help me guys!

    Sent from my DROID RAZR using Android Central Forums
    05-23-2012 04:21 PM
  2. d.meyer's Avatar
    Is there any way to block your number from goin out to other people while I text?? Can you turn it off n. On?? I just realized that it's my call back number not a number blocker! Ahhhh!

    Sent from my DROID RAZR using Android Central Forums
    05-23-2012 04:26 PM
  3. equishd's Avatar
    Best way i think would be get a Google voice number

    Sent from my T-Mobile G2 using Android Central Forums
    05-23-2012 04:28 PM
  4. d.meyer's Avatar
    Can I text through that??

    Sent from my DROID RAZR using Android Central Forums
    05-23-2012 04:35 PM
  5. d.meyer's Avatar
    Or an app where I can send multiple messages at 1 time that doesn't show my number

    Sent from my DROID RAZR using Android Central Forums
    05-23-2012 04:40 PM
  6. covard's Avatar
    Maybe I'm out of line, but you CAN text without your callback number. You hit the menu while in text messsaging and there is a place where you can disable the callback number being attached to any text that you send, or you can change the callback number, change or add a signature, etc.

    just an FYI
    05-23-2012 11:25 PM
  7. ak2j's Avatar
    Maybe I'm out of line, but you CAN text without your callback number. You hit the menu while in text messsaging and there is a place where you can disable the callback number being attached to any text that you send, or you can change the callback number, change or add a signature, etc.

    just an FYI
    This option is not working for me. My callback # still shows with either option.
    11-24-2012 10:30 PM
  8. tlacour's Avatar
    I'd suggest getting a separate phone for work.
    11-25-2012 11:59 AM
  9. cole2kb's Avatar
    I second Google Voice. You can text through the app and then they see your Google number and not your phone number.

    Sent from my Motorola RAZR MAXX using Tapatalk 2
    bradenfontaine likes this.
    11-25-2012 12:20 PM
  10. durango992007's Avatar
    Going back to disabling your call back number in the messaging settings, go to edit call back number, and delete it, make it blank. See if that works.

    Sent from my DROID RAZR using Android Central Forums
    11-25-2012 01:49 PM
  11. ak2j's Avatar
    Going back to disabling your call back number in the messaging settings, go to edit call back number, and delete it, make it blank. See if that works.

    Sent from my DROID RAZR using Android Central Forums
    Does not work. Call back # still shows up.
    11-26-2012 08:42 AM
LINK TO POST COPIED TO CLIPBOARD