1. ryangillman's Avatar
    Whenever I try to use my camera it just shows black and then it crashes. Apps that use the camera don't work either, including flashlight apps that use the flash. Does anyone know what's wrong or how to fix it?
    01-24-2012 10:44 AM
  2. johndm78's Avatar
    I had downloaded a upc scanner app. red laser our something I think it was called, and at some point my camera started doing the same thing coming on with black screen for a few second then crashing resetting the phone only helped for a day I deleted that app and one other don't remember what that one was, reset my phone and haven't had a problem since. Might be worth a shot.
    01-24-2012 12:32 PM
  3. fatboy97's Avatar
    Settings > Applications > Manage applications > All tab > Camera > Clear data... then try rebooting... then try the camera again.
    01-24-2012 01:03 PM
  4. SpyglassSally's Avatar
    Also try removing the app that is using the camera (flashlight?) and see if it still crashes. There might be an issue with it.
    01-24-2012 04:49 PM
  5. ryangillman's Avatar
    I've rebooted multiple times, cleared the data for the camera, and removed all of the camera apps but it still doesn't work.
    01-24-2012 06:09 PM
  6. fatboy97's Avatar
    I've rebooted multiple times, cleared the data for the camera, and removed all of the camera apps but it still doesn't work.
    First, do you still have any apps that USE the camera app???

    Secondly, did you remove all these apps, then clear data in the Settings > Applications > Manage applications > All tab > Camera... then reboot, and then try just the Camera app???
    01-25-2012 07:26 AM
  7. ryangillman's Avatar
    First, do you still have any apps that USE the camera app???

    Secondly, did you remove all these apps, then clear data in the Settings > Applications > Manage applications > All tab > Camera... then reboot, and then try just the Camera app???
    Yes I removed all the apps that use the camera and cleared the data, but it still doesn't work.
    01-25-2012 12:19 PM
  8. fatboy97's Avatar
    Yes I removed all the apps that use the camera and cleared the data, but it still doesn't work.
    Ok... well, unless you want to do a factory reset I'd suggest you bring it into a VZW store.
    01-25-2012 12:41 PM
  9. ryangillman's Avatar
    Ok... well, unless you want to do a factory reset I'd suggest you bring it into a VZW store.
    If I were to do a reset how would I backup/restore everything?
    01-27-2012 11:01 AM
  10. fatboy97's Avatar
    If I were to do a reset how would I backup/restore everything?
    If you were already rooted I'd recommend using Titanium Backup... but if you are not, then you can Backup Assistant will only back up some information... other than that you will have to download most everything from the Market again... and hopefully you have all your contacts, & calendar on Gmail which will restore automatically when you log into your Gmail account.
    01-27-2012 03:13 PM
  11. SpyglassSally's Avatar
    One other thing, have your camera Save point to your internal memory. Just to rule out a compatibility issue there.
    01-27-2012 06:19 PM
  12. SpyglassSally's Avatar
    If I were to do a reset how would I backup/restore everything?
    My Backup Pro will backup your applications, media and data to a SD card. No root required.
    01-27-2012 06:21 PM
  13. dontlookatme's Avatar
    My camera didn't work before and I did a factory reset. And it fixed it. Now every thing was going great and now my camcorder doesn't wanna work. Camera is OK. But not camcorder. I don't wanna do another factory reset.

    Sent from my HTC Edge using Tapatalk
    01-27-2012 06:21 PM
  14. dontlookatme's Avatar
    I cleared data and now my camera won't work. Damn I don't wanna do. Factory reset. Too much time and hassle.

    Sent from my HTC Edge using Tapatalk
    01-27-2012 06:40 PM
  15. onebrucelee's Avatar
    I have the same phone doing the same thing, i had update probably not the problem not sure anyway i removed all apps didnt change anything just a waste of time, hooked to my computer copied all did factory reset at verizon still no camera so they said same as i figured "stuck shutter" so they sending me a new one and i can keep this one. So yes dont waste your time.
    02-24-2012 05:24 PM
  16. zxphenomenalxz's Avatar
    This happened to my DROID x before. Try formatting ur SD card just make a back up. Has something to do with dcim folder and stuff..
    02-24-2012 11:05 PM
  17. Papa Lennie's Avatar
    When I try to go to the camera app, it would flash a blank screen and then go back to the main screen. I cleared the camera data and rebooted and now the camera and flash works.
    08-03-2012 09:58 PM
  18. tarthur's Avatar
    the camera in my droid razr stopped working about a week ago, reverting to the home screen every time i tried to use it. i tried every suggestion short of factory reset. i decided i would go to the vzw store today. BUT. last night i forgot to plug in the charger before bed. when i woke up, the phone was dead dead dead, so i charged it up and turned it on. about an hour later i noticed the phone was unusually cool to the touch but it was on and fully charged. on a hunch, i tried the camera. BiNGo! i can't explain it, but it works now. maybe worth a try to let the juice run out completely and restart? btw, it's still very cool to the touch. stange.
    08-27-2012 10:46 AM
  19. asoccer1's Avatar
    Not workin
    01-11-2013 11:17 AM
  20. carracerz14's Avatar
    Not workin
    You're gonna have to be more specific. Replying to a 5 month old thread with the words "not workin" doesn't really explain anything.

    Sent from my RAZR MAXXIMUS
    asoccer1 likes this.
    01-11-2013 08:20 PM
  21. asoccer1's Avatar
    When I try to enter my camera app it ether freezes or crashes an goes back to my home screen...... Only dose it with the back camera not the front one.... Also if the flash is on I take a pic and my flash stays on and I have to force quit my whole phone......ughhhhh somebody please help meeeeeee!!!!!!!!!!!!!!!
    01-12-2013 11:58 AM
  22. carracerz14's Avatar
    Settings>apps>all>camera>clear data, and also clear cache.

    Sent from my RAZR MAXXIMUS
    01-12-2013 12:17 PM
  23. Santouy's Avatar
    I had the same problem, I did restarts, cleared camera cache, fabric restore, nothing worked.. then I rememebered that the camara was using Micro SD to save pictures, so I turned my phone off, removed Micro SD card, turned my phone back on and problem solved. Then I inserted Micro SD card again and its working perfectly since then.
    Hope it works for you.

    Regards
    04-03-2013 06:45 PM
LINK TO POST COPIED TO CLIPBOARD