Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default EG22 Roaming Options grayed out?

    Stock/Rooted EG22 GB Leak. (Odin'd the EG22 .tar, Odin'd cwm3.1.0.1.tar, installed su.zip)

    Settings -> wireless and network -> Roaming.
    Under the "roaming settings" and "roaming guard", I cannot change any of the options. I prefer to have the phone just disable data while roaming, but NOT warn me when in this state. I also do not want it to "guard" against roaming calls. I want to uncheck the roaming guards, and disable domestic data roaming. This is the first build that I've seen that does not allow me to change any of these settings. Is there a known workaround for this?

    Roaming settings are locked in as follows:
    Domestic
    Voice [x]
    Data [x]
    International
    Voice [x]
    Data [x]

    Roaming Guard are locked in as follows:
    Domestic
    Voice [x]
    Data [ ]
    International
    Voice [x]
    Data [x]

    ====================
    How _I_ want them set:
    Roaming settings are locked in as follows:
    Domestic
    Voice [x]
    Data [ ]
    International
    Voice [ ]
    Data [ ]

    Roaming Guard are locked in as follows:
    Domestic
    Voice [ ]
    Data [ ]
    International
    Voice [x]
    Data [x]
  2. #2  
    tomy2001's Avatar

    Posts
    250 Posts
    Carrier
    EH17 U. Metamorphosis 2.0

    Default Re: EG22 Roaming Options grayed out?

    I downloaded this leak EG22 and I did not have any problem changing the option that you are talking about. I use Roam Control all the time, so I had to change the roam option. Try to download this:

    [ROM] Stock/Deodexed update.zip for EG22 (CWM Flashable w/ root) - xda-developers
    This link is from Paul's EG22 roms, themes and Mods. Good luck!!!!

    PS: You must have the latest CWM I think is the purple cmw. Do not flash it. Make sure you have this cwm.
    ratsttam likes this.
  3. Thread Author  Thread Author    #3  

    Default Re: EG22 Roaming Options grayed out?

    Quote Originally Posted by tomy2001 View Post
    I downloaded this leak EG22 and I did not have any problem changing the option that you are talking about. I use Roam Control all the time, so I had to change the roam option. Try to download this:

    [ROM] Stock/Deodexed update.zip for EG22 (CWM Flashable w/ root) - xda-developers
    This link is from Paul's EG22 roms, themes and Mods. Good luck!!!!

    PS: You must have the latest CWM I think is the purple cmw. Do not flash it. Make sure you have this cwm.
    So using ODIN to put the EG22 leak (I got it directly from samfirmware.com), and using the tar version of CWM purple to gain cw recovery is the root of my issue? I'll give that update.zip a shot tomorrow and post back with the results.
  4. #4  

    Default Re: EG22 Roaming Options grayed out?

    Quote Originally Posted by ratsttam View Post
    So using ODIN to put the EG22 leak (I got it directly from samfirmware.com), and using the tar version of CWM purple to gain cw recovery is the root of my issue? I'll give that update.zip a shot tomorrow and post back with the results.
    Best thing to do since your running the stock unrooted leak is to use the following link and use that Odin package. It will be deodexed, install CWM and be rooted. Basically the same version as tomy suggested just this one is an Odin package to make it more convenient for you so you don't have to root your current setup and install CWM, etc. etc..

    [Odin]Stock EG22 Deodexed with CWM 3.1.0.1/Root/Busybox 1.18.4
  5. #5  
    striker1211's Avatar

    Posts
    3 Posts
    Global Posts
    4 Global Posts

    Default Re: EG22 Roaming Options grayed out?

    Just wanted to Chime In and say I am on EI22 using roam control and had the same problem. To fix it i had to RoamControl back to Automatic, go to the "roaming mode" and select Automatic, then I could change the other settings. Then I RoamControl'ed back to roaming and it saved my settings.
  6. #6  
    Skunkape60's Avatar
    Retired Ambassador

    Posts
    4,518 Posts

    Default

    Quote Originally Posted by striker1211 View Post
    Just wanted to Chime In and say I am on EI22 using roam control and had the same problem. To fix it i had to RoamControl back to Automatic, go to the "roaming mode" and select Automatic, then I could change the other settings. Then I RoamControl'ed back to roaming and it saved my settings.
    That's the same as mine and was the same with my froyo before.

    Sent from my SPH-D700 using Tapatalk

Posting Permissions