Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  
    StoneRyno's Avatar

    Posts
    249 Posts
    Global Posts
    3,021 Global Posts
    ROM
    CM10

    Default SD card not mounting or failing to mount

    Some time today out of the blue the SD card no longer mounts or fails to mount, with no changes made to my epic since it worked correctly hours earlier. It is a patriot 32GB card I bought not too long ago. I split it into two partitions the original partition shrank down and a second ext4 partition for link2sd when I first got it. It has been working fine for months or longer as I can't recall how long I had it but it has been a long time now. First it was the original partition that wasn't mounting and now the ext4 isn't either. I went into CWM hoping that I could do something in there but even it can't mount the SD card. When I removed the SD card and insert it back into it's slot it is recognized as inserted but seconds after the SD card is safe to remove message comes up as if I had told it to unmount it. Please help me fix this. Bare minimally I will need to copy the data off of the SD card on to my PC I only hope that I can do so using the mico SD to standard SD adapter that came with the card and the SD card reader I have. So that the card can be reformatted or whatever if that is the only way to fix this.
  2. #2  

    Default Re: SD card not mounting or failing to mount

    Any progress/updates? I'm having similar trouble. I reset my HTC Thunderbolt (32GB sd card, Ice Cream Sandwich) last night, and now none of my apps show up. Under Settings, the card shows that it is mounted. I try to unmount it, but it won't mount again. When selecting "Mount SD Card", all I get is a blank screen with the word, "Reset?" with no options for a response.

    Frustrating. I want my old OS back.
  3. #3  

    Default Re: SD card not mounting or failing to mount

    Might be the Rom you are using, or the SD card reader. Try flashing a different rom.
  4. Thread Author  Thread Author    #4  
    StoneRyno's Avatar

    Posts
    249 Posts
    Global Posts
    3,021 Global Posts
    ROM
    CM10

    Default Re: SD card not mounting or failing to mount

    I've upgraded to the S4 and have new info. When inserting the SD card into it, the card is recognized but reported as blank or of an unsupported format and is in need of formatting. So it sounds to me like the partition was damage. And because no matter what PC or non android device I use doesn't recognize the card as being present it looks like I need to be able to recover the partition or data from the partition on the S4 itself. Which means I need to know what utilities I can install and the steps needed to be performed to do so. At this point I'm waiting for help on transitioning my data from my epic to the S4 and if I need to root or not and if I will be able to revert back to stock if something were to go wrong. Head over to my post on that if you have any help to offer on that other subject.

Similar Threads

  1. 'Failed to mount/unmount sd card' What gives?
    By Mingneh in forum T-Mobile HTC Sensation
    Replies: 4
    Last Post: 01-20-2014, 12:51 PM
  2. SD Card not mounting to PC
    By Maelstrom728 in forum LG Optimus S
    Replies: 2
    Last Post: 08-11-2012, 06:55 PM
  3. new sd card not mounting.
    By nevr.4get.911 in forum HTC EVO 3D
    Replies: 0
    Last Post: 08-22-2011, 02:18 PM
  4. SD Card not being mount to droid 2
    By allaboutnewphone in forum General Help and How To
    Replies: 3
    Last Post: 04-14-2011, 01:44 PM
  5. SD Card not mounting on Mac OSX
    By patrickhills in forum HTC EVO 4G
    Replies: 1
    Last Post: 06-04-2010, 05:04 PM

Posting Permissions