Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
Like Tree2Likes
  • 1 Post By sbutcher
  • 1 Post By Droidini
  1. Thread Author  Thread Author    #1  

    Default Unable to pair S2 with Plantronics PLT_M50

    Hello Droidians,

    I am unable to pair my galaxy S2 ICS 4.0.4 with bluetooth Plantronics PLT_M50. I am getting the error incorrect pin or password. I am not get prompted to enter anything. I even checked the Bluetooth folder when trying to pair it and had zero files.

    It worked fine before the upgrade from GB 2.3

    Any ideas?

    thanks in advance....
  2. #2  

    Default

    Quote Originally Posted by Droidini View Post
    Hello Droidians,

    I am unable to pair my galaxy S2 ICS 4.0.4 with bluetooth Plantronics PLT_M50. I am getting the error incorrect pin or password. I am not get prompted to enter anything. I even checked the Bluetooth folder when trying to pair it and had zero files.

    It worked fine before the upgrade from GB 2.3

    Any ideas?

    thanks in advance....
    The ICS update screwed up a lot of things, but as for a fix, I really don't know..

    Sent from my SPH-D710 using Tapatalk 2
  3. #3  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    Interesting....I have the exact same headset and had no trouble pairing after the update.

    Steps I took where to put the headset into pairing mode (Hold down call button until red and blue lights flash)
    Then go to Bluetooth and search for new devices.
    Click on PLT_M50
    should pair right up. If prompted for a password try all zeros.

    Hope that works for ya.....
    Evadelparaiso likes this.
  4. Thread Author  Thread Author    #4  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    That is the thing, I'm not prompted for a password. It does find the bluetooth set but then displays the error. I was hoping I can modify a file to enter 0000 but don't know which one.
    butcher what is your kernel version? Is it rooted?
  5. Thread Author  Thread Author    #5  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    Okay where is the icon for "embarrassed?" Here it is!!!!
    I totally messed up on trying to pair the BT. Unfortunately I was holding the volume button down and not the "call" button. (My other BT had the call button on the side hence why I kept pressing that darn button) The call button is on the front of the BT and not the side.
    Good news is after following the instructions as per previous post by "sbutcher" it worked. I eve paired it to my Galaxy tab.

    thanks everyone....
    Evadelparaiso likes this.
  6. #6  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    thank you. this work for me!
  7. #7  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    Was running into the same mistake, then I found the right button and aparently got paired.
    Anyhow, the connection is no going through.
  8. #8  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    In a matter of some restarts and unpairing other devices, it has ended up dully paired on working now.
  9. #9  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    I has the same problem for 2 days and did many things including resetting the phone to factory but did not works until I press the call bottom for 5 seconds then get pair done what a situation now is ok very simple action but did not see it before.

    Thanks
  10. #10  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    Wow!!! Thanks a lot fr the soln... it was so easy to pair following the instructions given... great!! It works
  11. #11  

    Default Re: Unable to pair S2 with Plantronics PLT_M50

    Hello, I have headset charged and powered on, it does not show the Red/Blue indicator ... when I turn it on ... it shows blue and then no lights. when I press the call button on BT headset the blue light just blinks and stops no of time I press the call button. Also when I hold it for long, it shows red light and turns off.. "not able to pair as it is not visible in any of my 3 android mobile phone". It was working fine earlier about a month back. Can anyone help fix this?

    Thanks.

Posting Permissions