Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default PROBLEM Seidio Innocell 3500mAh Extended Battery EVO

    Guys I need some help. I purchase the 3500 mah battery it was working great. However my phone was not getting 4G and Sprint recommended I do a factory reset and since then my batter sucks I cannot even get half day.

    I need help
  2. #2  
    2CupsWithString's Avatar
    passionately curious

    Posts
    2,809 Posts
    Global Posts
    2,825 Global Posts

    Default

    Are you rooted?
  3. #3  
    He123321's Avatar

    Posts
    226 Posts
    Global Posts
    793 Global Posts
    ROM
    Stock/Rooted

    Default

    Have you contacted the manufacture to see if they have come across such an issue in the past? Give them a call, and see what they have to say.
    Rolling with Sprint since 3/99...
  4. #4  
    eye4ni's Avatar

    Posts
    279 Posts
    Global Posts
    866 Global Posts

    Default

    Maybe you need to calibrate the battery again? You know, charge, unplug, plug back in till light turns green, repeat 100 times...
    Send files between your Android and your PC with Dropbox - Click here
  5. #5  
    MikeBinOK's Avatar

    Posts
    308 Posts
    Global Posts
    449 Global Posts
    ROM
    boring ol' stock

    Default

    Did you have 4G before you installed the 3500 battery?
    Palm V-->Palm Vx-->Palm m505-->Garmin iQue3600-->Treo 650-->Treo 755p-->Palm Pre-->EVO 4G-->EVO 3D-->Droid Razr Maxx-->Galaxy S4
  6. Thread Author  Thread Author    #6  

    Default 3500 battery

    No my EVO is not rooted and the manufacture has not seen this problem. and no my 4g is still not working
  7. Thread Author  Thread Author    #7  
  8. #8  
    geekaren's Avatar

    Posts
    85 Posts
    Global Posts
    216 Global Posts

    Default

    Quote Originally Posted by mannyvigi1985 View Post
    No my EVO is not rooted and the manufacture has not seen this problem. and no my 4g is still not working
    And you are *sure* you're in a 4g covered area, right?

    The reason I ask: I near live a 4g area but there is not 4g in my neighborhood. If I set my phone to 4g while at home, it indicates "scanning" and my battery is depleted quickly.

    Otherwise...
    If you are experiencing fast battery drain with 4g turned *off*, I'd suggest doing another factory reset -- you'll lose your data but otherwise it can't hurt.
  9. #9  
    IIJBII's Avatar

    Posts
    312 Posts
    Global Posts
    699 Global Posts

    Default

    Quote Originally Posted by mannyvigi1985 View Post
    Guys I need some help. I purchase the 3500 mah battery it was working great. However my phone was not getting 4G and Sprint recommended I do a factory reset and since then my batter sucks I cannot even get half day.

    I need help
    mannyvivil1985 - Have you setup your phone exactly how it was before the wipe (Sync settings, email, etc.)?

    Were you using any apps to manage the battery use?

    What was your use of the device and batter life like before the wipe? What is it now?

    Also, many folks have mentioned if you are using 4G it does seem to drain the battery faster. Not sure if you are using 4G or turning it off when you're not using it?

    Based on what you said I would suspect/guess its the device (or a setting) that's different not the battery. As you mentioned the battery was working great before the wipe which tells us nothing really changed with the battery, but rather the phone. This is just a guess based on what you mentioned.

    Please keep us posted. I also have the Seido Innocell 3500mAH battery and haven't had any issues. I've not done a wipe to see if it changes anything but performance all around seems pretty good.

Posting Permissions