1. JDWallace's Avatar
    I searched the Android Central forums and found nothing. My son's 5" Galaxy player connects to WiFi and has a solid connection, but it can't connect to market or the internet or anything needing internet. It says "No Connection" and it gives a "Retry" box. I have restarted the WiFi, rebooted the players and still nothing. Any ideas out there in Android land??
    03-15-2012 12:07 PM
  2. beantown's Avatar
    I have seen that too at times. I haven't seen it on my Galaxy Player 5" or my Motorola Photon 4G, but I used to see it on my EVO 4G. I would keep tapping the retry button usually that should work. Maybe you can try to forget all wireless networks, and re-input your wireless information again...
    03-20-2012 12:46 PM
  3. JDWallace's Avatar
    I can tell you what finally worked for me over the weekend. I ended up factory restoring the thing about 4 times. The last time it finally connected. Strange that it took that many times. I still don't think it was the WiFi because I restarted it multiple times before factory resetting the Galaxy Player.
    03-20-2012 06:30 PM
  4. whiteshadow001's Avatar
    I can tell you what finally worked for me over the weekend. I ended up factory restoring the thing about 4 times. The last time it finally connected. Strange that it took that many times. I still don't think it was the WiFi because I restarted it multiple times before factory resetting the Galaxy Player.
    Mine did this a lot too. I factory restored it and it finally worked

    Sent from my Galaxy Nexus using Tapatalk
    03-20-2012 06:33 PM
  5. JDWallace's Avatar
    The problem I have is that you shouldn't have to factory restore to get it to reconnect to the Wifi. I am wondering if there is an issue somewhere that they haven't fixed??
    03-20-2012 09:05 PM
  6. Captian4Phones's Avatar
    If youre using JuiceDefender that could be causing issues. I also experienced it when i was using a launcher. I dont remember which one but uninstalling didnt help. I ended up having to factory reset.

    SGS3, 5-inch SGP, BB9300, and others.
    01-13-2013 11:21 AM
  7. GelliHart's Avatar
    If it starts to do it again, do this: Settings.date and time>Set date, okay here you can set to a random date and then reset it to the normal date> back>select time zone, do the same thing>back>set time, usually the time is messed up so just set the time. Had to do this a number of times.
    08-16-2013 08:59 PM
  8. nguyen18712's Avatar
    It didn't work for me so can someone please halp me?
    12-22-2013 04:38 PM
  9. Melissa Peterson's Avatar
    Thank you!! It fixed mine
    02-07-2014 09:14 AM
LINK TO POST COPIED TO CLIPBOARD