Hi there,

I am having an issue with my MK808B connecting to my home network. I can connect fine to numerous other hotspots (samsung galaxy nexus, ipad, mifi, etc), but for some reason it does not want to connect to my home network.

The MK808B shows strong signal, but every time I hit "Connect", it will say connecting for a few seconds and then just revert to saying "Saved, Secured" but without any connection being made. I have of course tried all the normal stuff about rebooting routers, etc. I have tried "Forgetting" the network several times and re-connecting - no luck. I tried setting a static IP address to my home computers thinking there might be an IP conflict issue, but that doesn't seem to be it. I also tried taking off all security on the network, but it still does the same thing.

Some of the other forums I have looked at suggest going to some "Advanced" wifi settings on android, but the MK808b doesn't seem to have that option that I can find.
I looked into my router settings and I do not have any unusual permission settings that I can tell - i.e. no "MAC address filtering" or "Access Control" enabled.

My router is a Cradlepoint MBR-1000, and I am tethering it to a Pantech UML290 Modem for Verizon LTE internet.

I can connect fine to this network on several other devices, including the Samsung Galaxy Nexus.

Admittedly I am no network expert, and it seems like there must be some simple issue that I am overlooking.

Anybody got any ideas?

Thanks!