Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 29
Like Tree1Likes
  1. Thread Author  Thread Author    #1  

    Default Your device isn't compatible with this version

    Hello everyone.
    Sorry if my question sound stupid but I am really a newbie to Android.
    most of the things I try to download from play store (like: Waze, whatsapp, Fruit Ninja Free, Bad Piggies, Jetpack Joyride, flirt maps etc) say "Your device isn't compatible with this version" why is that?
    I got a Chinese phone "Hero H5500" with android version 4.0.3 so what can the problem be?
    I really wanted Waze and whatsapp so I looked very hard and found APK files for them and the apps running great. so what is the problem.
    The phone is 3 days out of the box. (no rooted)
    Is it safe to download apk files?

    Thanks
    Thanked by:
    Xiao Jun likes this.
  2. #2  

    Default Re: Your device isn't compatible with this version

    most propably it thinks you are in china and is region locked?? thats a huge possibility.
  3. Thread Author  Thread Author    #3  

    Default Re: Your device isn't compatible with this version

    TY Still1, But what does it means? What do I do?
  4. #4  

    Default Re: Your device isn't compatible with this version

    Mostly when you insert US sim it will automatically identify as US region and will enable the app.

    lets just verify if it is country restricted go to waze here https://play.google.com/store/apps/details?id=com.waze

    click install and in the dropdown your device will be listed with a question mark. hoover over and what does it says
  5. Thread Author  Thread Author    #5  

    Default Re: Your device isn't compatible with this version

    Its read "This Item is not compatible with your device"

    BTW
    Its call my device "Pelephone Alps H5500" not Hero H5500
  6. #6  

    Default Re: Your device isn't compatible with this version

    if you have root you can install market enabler to enable the US region.
  7. Thread Author  Thread Author    #7  

    Default Re: Your device isn't compatible with this version

    Can't be my only option, is it?
  8. #8  

    Default Re: Your device isn't compatible with this version

    Quote Originally Posted by RobinCris View Post
    Can't be my only option, is it?
    not sure if other method exist. i will let others answer that.
  9. #9  

    Default Re: Your device isn't compatible with this version

    Well, my situation is a little different, I think. I have updated Android on my Skyrocket a few times and it has always been ok. Kies syncs with the phone when I plug it in, but not since the last patch ( a couple of days ago). I believe that is 4.0.1. Now the phone won't sync and I get a message that the 'device is not compatible with Kies 2.0". The driver says it is installed and the device is ready to use, however, the Kies software cannot sync with the phone. A window displays and says that the driver did not install correctly (even though another window says that the device, memory, sim card, etc, are all ready to use). Do I have to remove Kies, and the and then re-install everything? I have a US phone, in the US, with a US driver's license, if that helps.
  10. #10  

    Default Re: Your device isn't compatible with this version

    Most the time if it's not compatible its because the processor in your phone isn't strong enough to handle the functions of the app, especially if it requires a lot of animation and motion, other times it's because service providers block certain apps.

    ~~HTC Evo Design~~
    ~*Purple Android*~
  11. #11  
    Rukbat's Avatar

    Posts
    2,056 Posts
    ROM
    X-Note7.0.1

    Default Re: Your device isn't compatible with this version

    It can also be due to your hardware not being compatible with the app. For instance, most barcode readers require an autofocus camera. It can also be just the way the developer listed the app, so for some reason your phone won't be listed as compatible.

    I've never found an apk that would cause a permanent problem with the phone - the worst I've seen with an apk for a "non-compatible" app is that the app won't work, or works poorly.
  12. #12  

    Default Re: Your device isn't compatible with this version

    Acer betouth e140
  13. #13  

    Default Re: Your device isn't compatible with this version

    what mean Your device isn't compatible with this version...this word is come out of line pop...please let me know what problem
  14. #14  

    Default Re: Your device isn't compatible with this version

    I got my android tablet shipped from China, when I try to download Pinger text free app, it says "This app is incompatible with your Unkown Q88, Unknown Q88, this item is not compatible with your device."
  15. #15  

    Default Odp: Your device isn't compatible with this version

    Quote Originally Posted by LorriLoves View Post
    I got my android tablet shipped from China, when I try to download Pinger text free app, it says "This app is incompatible with your Unkown Q88, Unknown Q88, this item is not compatible with your device."
    Unknown Q88 is name of your phone registered in your system and your device missing something or system is too old
  16. #16  

    Default Re: Odp: Your device isn't compatible with this version

    I just got it, it can't be too old. What am I missing in my device, how do I check?
  17. #17  

    Default Re: Your device isn't compatible with this version

    Ask the developer.





    Sent from my Nexus 4 using Android Central Forums
  18. #18  

    Default Re: Your device isn't compatible with this version

    i am facing compatible issue what should i do ????????????
  19. #19  
    Rukbat's Avatar

    Posts
    2,056 Posts
    ROM
    X-Note7.0.1

    Default Re: Your device isn't compatible with this version

    Most Chinese phones aren't really Android-compatible, so most Android apps won't work on them. The solution is to not buy Chinese phones until the Chinese learn to make compatible phones (which will cost them more, so they won't be able to sell the phones cheaper than the name-brand phones, so it won't ever happen - so just don't buy Chinese phones).
  20. #20  

    Default Re: Your device isn't compatible with this version

    Every time i try to download apps like ( Instagram , twitter , oovoo etc.) It say your device isnt compatible with this device . Whyyyy? Please help
  21. #21  

    Default Re: Your device isn't compatible with this version

    Quote Originally Posted by alexanicole_xoxo View Post
    Every time i try to download apps like ( Instagram , twitter , oovoo etc.) It say your device isnt compatible with this device . Whyyyy? Please help
    Welcome to Android Central! What device do you have, and what version of Android is it running?
  22. #22  

    Default Re: Your device isn't compatible with this version

    Andriod version is 4.2.2 jelly
  23. #23  

    Default Re: Your device isn't compatible with this version

    I have a samsung galaxy grand neo the same problem I live in egypt there are things that says your device isn't compatible with this version
  24. #24  

    Default Re: Your device isn't compatible with this version

    I tried downloading instagram on my tablet and it said your device is not compatible with this version what does this mean?? Help??!!
  25. #25  

    Default Re: Your device isn't compatible with this version

    Quote Originally Posted by Lily Renee View Post
    I tried downloading instagram on my tablet and it said your device is not compatible with this version what does this mean?? Help??!!
    Welcome to Android Central! What device do you have? Apps are not always compatible with all devices. You could email the developers to ask them if there will be compatible version released, but it's unlikely.

    Posted via Android Central App--please excuse the brevity and any typos!
Page 1 of 2 12 LastLast

Similar Threads

  1. Is there any way to fix "your device isn't compatible with this v
    By jimmiegeddes in forum Verizon Galaxy Nexus Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 03-24-2012, 10:24 PM
  2. Any way to fix "your device isn't compatible with this version"?
    By jimmiegeddes in forum Verizon Galaxy Nexus
    Replies: 3
    Last Post: 03-24-2012, 12:01 PM
  3. Rooted Nook Color your device isn't compatible with this item
    By melanie_mg in forum Barnes & Noble Nook Color
    Replies: 3
    Last Post: 03-21-2012, 11:11 AM
  4. Is anyone else noticing "device is not compatible with this item"
    By f75gunslinger in forum Verizon Fascinate
    Replies: 9
    Last Post: 01-23-2012, 02:43 PM
  5. Your device is not compatible with this item!
    By Adibidah in forum Barnes & Noble Nook Color
    Replies: 8
    Last Post: 10-01-2011, 11:08 AM

Posting Permissions