I have a Samsung Epic and recently installed Swiftkey 3. I'm not sure if that's related to my problem, but lately I don't get any auto-correction when I type emails, whether I use the physical keyboard or the virtual Swiftkey one. When I say "auto-correct", I'm talking about capitalizing the first word of a sentance, putting the apostrophe in contractions, capitalizing the "I" automatically when it should be the word "I" etc.

Auto correct works fine in texts and in other situations, just not emails. I've gone into the settings for emails and I can't see anywhere that I can turn it on or off or see any other way to change it. Separately, I've gone into the settings for Swiftkey 3 and don't see any settings that would seem to apply or any settings related specifically to emails. Also, as indicated, I don't have auto correct when using the physical keyboard either.

Thanks for any help anyone can give.