1. navedoperez's Avatar
    Hi! I'm new to Android and I have some questions..

    The easier one, how do I auto-sync google apps such as gmail and music? I'm on 4.2.
    When I go to Settings > Scroll down to Accounts > Google, I see a small message saying "Sync is OFF". If I click on that I can manually sync, but I don't see any options for autosync.

    Also, will getting Cyanogenmod benefit me since I already have 4.2? From my understading, Cyanogenmod is an alternative to the stock Android ROM, that lets users update to the newest firmware earlier than waiting for it to officially rol out for their device. Am I right on this? Or does Cyanogenmod do that plus add new features?

    And if they do, what is an example of these features? I want to know if it is worth the root and voiding my warranty.

    I know I've asked a lot but I would appreciate some help!
    12-03-2012 03:24 PM
  2. PvilleComp's Avatar
    If you go into Google under Settings -> Accounts and then tap on your username it should bring up the list of Google features to sync.

    As far as loading Cyanogenmod, that's up to you and what phone you have. Does Cyanogen support your phone directly? If so then it's a great ROM and I would highly recommend it (I run it as a daily driver on my phone.).
    12-03-2012 07:45 PM
  3. Matt Lucas's Avatar
    Yes but there is no auto-sync option!
    12-06-2012 02:15 PM
  4. mrccentral's Avatar
    I have the very same problem. Somehow since I upgraded to CM 10.2 automatic sync is off. The big problem is I can't find out how to turn it back on again. There is no option in the Accounts section in Settings (some post on the net states that just go to "Settings" - "Accounts & Sync". But there is only "Settings" - "Accounts". There seems no way to enable sync here. Only to add account, remove accounts and manually start syncing

    Guess the "missing Sync" might be because of the rather new "Profile" option. Inside here you can set if synchronizing is to be done. But it did not work. I also tried to disable "Profile" but that did not work either.

    Its rather useless for me to have a phone where i have to synchronize manually! Please help. Am I missing something?
    02-28-2013 08:17 AM
  5. afir's Avatar
    I had the same problem.
    I succeeded to turn on notification by modifying setting inside the Gmail application. Once inside, click on your account name (On the left), and then check "Data Usage - SyncGmail" option. You should be presented with the (system) window that gives you an option to turn on synchronisation.
    05-09-2013 01:52 PM
  6. Kevin Sadler's Avatar
    Settings > Google > Google+ > Photos & Videos then enable EVERYTHING
    05-11-2013 12:58 AM
  7. 2anyone's Avatar
    same problem here: usually, there is a tick after every sync options, but now, the thick is disappeared.

    I wipe whole system & data, and reinstall cm & google app pack, the tick is back, auto sync is no problem.

    so I believe there must something damaged the "tick" thing.

    anyone had any suggestion? thank you.

    solution:

    that's because I turned auto sync off. Turn that on, all ticks appeared, and sync works again.
    06-11-2013 04:39 AM
  8. akgonzal's Avatar
    I had this same problem and what fixed it was going into: (Phone) Settings --> System (setting) ---> Hardware Keys --> Then turn on "Enable Custom Actions" and turn on "Show Action overflow." Also click on "App Switch Key (long press)" to turn on the "Open/close menu" option from the inner list.

    This produced the 3 vertical dots on my photo gallery (which was previously non-existent) so I can delete the pictures when I am viewing them in large mode. It also provided the 3 vertical dots on my Gmail account so you can find the settings to auto sync.

    To auto sync, after enabling the above mentioned hardware keys, open your Gmail account like you do when you are checking your email. Then hold down the bottom right button on your phone (the built in "app switching" button; it looks like a square on top of another square). Holding it down will pop up a list of Gmail options. Click on --> "settings" ---> then click on your personal username "something@gmail.com" ---> then another list will pop up with a check box next to the "Sync Gmail" option. Holy Thank Goodness it works!
    06-23-2013 11:21 AM
  9. marcelogabriel's Avatar
    To autosynch:


    Android Settings > Data Usage > Options menu (left button ) > Select Auto-Synch data option
    09-27-2013 10:46 AM
  10. BorbingoBoy's Avatar
    Plz give me apk from G-Apps that you need to sign in to Google for other G-Apps, plzzz!
    05-05-2014 08:47 AM
  11. Ironmarley's Avatar
    Exactly !
    08-19-2014 07:24 AM
  12. hugh0079's Avatar
    thanks its working
    09-30-2014 08:32 AM
  13. danielb QXL's Avatar
    Man thank you so much. Simple solution. It would not occur to me ever. I've become a retard, horror. On the other phone I have CM 12.1 and are completely different control commands from the commands for CM 11, on which I have a problem with the sync (I had a problem, sorry). Ah, I'm probably being too used to a Lollipop 5.1.1..
    12-01-2015 08:43 AM

Similar Threads

  1. Difference Between Background Data and Auto-Sync
    By JonathanY in forum Virgin Mobile Optimus V
    Replies: 12
    Last Post: 01-01-2012, 12:44 AM
  2. Google Navigation, and Ford Sync
    By ammarmon in forum Motorola Droid X
    Replies: 0
    Last Post: 01-20-2011, 08:30 PM
  3. Facebook and Auto-Sync
    By stevenhglee#AC in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 08-26-2010, 12:53 PM
  4. Replies: 4
    Last Post: 06-15-2010, 12:01 AM
  5. Auto sync and battery life?
    By DonnieAles in forum HTC EVO 4G
    Replies: 4
    Last Post: 06-07-2010, 05:11 AM
LINK TO POST COPIED TO CLIPBOARD