Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Android SDK Manager, default browser not displaying images

    I am loading my web pages into the default browser in the Android Emulator using Xampp and localhost (as 10.0.2.2). The pages load okay but no images are displayed.

    In browser settings, under bandwidth management, ‘Load Images is ticked’. Google displays images if I do an image search.

    Turning off anti virus and firewall makes no difference.

    Appreciate any suggestions, thanks.
  2. #2  

    Default Odp: Android SDK Manager, default browser not displaying images

    Do site works right on your pc browser? Did you tested on real device or/and diffrent system versions? Do your site images are on your server or somewhere else? How your images are pathed in html? Full url or starting with /?
  3. Thread Author  Thread Author    #3  

    Default Re: Odp: Android SDK Manager, default browser not displaying images

    Thanks for the feedback Shadowriver.

    The site works fine in any browser when hosted on my desktop using xampp as a localhost server. I am still developing so there is no online hosting yet. I don't have a real android device to test it but it does display the images correctly when running android 4.1 inside virtual box.

    The images are on my pc and have either:
    relative paths e.g. src="../pictures/picture.jpg"
    or
    absolute paths e.g. src"/websitefolder/pictures/picture.jpg".

    All images in the Emulator just display as a '?' inside a blue box.

    Cheers, I would welcome any suggestions.
  4. #4  

    Default Odp: Android SDK Manager, default browser not displaying images

    Well it seems its system specific probelm then, did you tried diffrent systems on emulator?

    Also if you running android on virtual box for speed try using x86 android system image on sdk emulator it should use virtualisation too

    Im not sure if stack browser has it but you might try to use webkit remote debuging whick let you access browser via webkit inspector, it should show you whats wrong
    Thanked by:
  5. Thread Author  Thread Author    #5  

    Default Re: Odp: Android SDK Manager, default browser not displaying images

    I have tried different combinations of device and android versions, still no images displayed. Also tried 2 different PC's.

    You are correct x86 would be quicker. What is the difference between using an ARM or x86 image in the sdk emulator? I want to be sure the outcome correctly reflects an android device.

    I don't think there is any inspector in the android browser. I will take a look.

    Thanks for your help.
  6. #6  

    Default Re: Odp: Android SDK Manager, default browser not displaying images

    Quote Originally Posted by Cran Fan View Post
    I have tried different combinations of device and android versions, still no images displayed. Also tried 2 different PC's.

    You are correct x86 would be quicker. What is the difference between using an ARM or x86 image in the sdk emulator? I want to be sure the outcome correctly reflects an android device.

    I don't think there is any inspector in the android browser. I will take a look.

    Thanks for your help.
    x86 image if you have CPU with virtualization acceleration (check if you can turn it on in BIOS usally it's off by default) will run Android in near native speed of PC, ofcorse it wont be accurate as it will be faster then real device (i think) but faster then ARM emulator.

    By inspector i mean remote inspector :> you connect to phone browser with your desktop browser nad on desktop site you will have full webkit inspector, it's actully webkit feature and technicly all webkit browser can do that, but there need to be option to turn it on which not all browser implement i know Chrome for Android have it

    Thanked by:
  7. Thread Author  Thread Author    #7  

    Default Re: Odp: Android SDK Manager, default browser not displaying images

    Thanks, I will have a look at the link.

    My concern with using an x86 image was more whether or not the page would look the same as a real device i.e. same layout pixel perfect.?

Similar Threads

  1. S Note not displaying images/ graphs in PDFs
    By slo3 in forum Samsung Galaxy Note 10.1
    Replies: 5
    Last Post: 01-22-2013, 07:53 PM
  2. Hep installing Android SDK manager
    By amydaveg in forum Verizon Galaxy Nexus Rooting, ROMs, and Hacks
    Replies: 9
    Last Post: 10-09-2012, 03:12 PM
  3. Android 2.2 Default Browser: Save media for later playback?
    By Dark Penguin in forum General Help and How To
    Replies: 1
    Last Post: 09-05-2011, 02:43 PM
  4. Images/Photos do not display on Facebook wall.
    By Gussy2000 in forum Android Applications
    Replies: 6
    Last Post: 04-19-2011, 08:04 PM
  5. Replies: 9
    Last Post: 09-23-2010, 03:59 PM

Posting Permissions

B