Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  
    scramer's Avatar

    Posts
    74 Posts
    Global Posts
    75 Global Posts

    Default Can't connect HTC EVO to PC with usb cable

    please help. After updating to 2.2 (I do not know that this is the cause, this is just the first time that I noticed it) when I connect my HTC Evo to my computer nothing pops up on my phone asking me what I want to do, nor is there a notification on the phone telling me that I am connected. It worked a week ago.

    Default Connection > Disk Drive
    Ask Me about USB connection type whenever I connect my phone to a pc is checked.

    On my laptop, it will show a removeable drive F, but if I click on it, it will ask me to "insert a disk".

    I tried my husband's HTC Evo (which has not been upgraded) and it will connect the way it is supposed to, so it is not the cable nor my laptop.

    Any thoughts?

    Thanks.
  2. #2  
    Dirrk's Avatar

    Posts
    243 Posts
    Global Posts
    245 Global Posts

    Default

    Do you have debugging enabled?
    Google Plus+
    Current Devices: Samsung Galaxy Tab 10.1 - Samsung Charge
  3. Thread Author  Thread Author    #3  
    scramer's Avatar

    Posts
    74 Posts
    Global Posts
    75 Global Posts

    Default

    Quote Originally Posted by Dirrk View Post
    Do you have debugging enabled?
    I had to go look up where that was. No, it is not enabled, and I forgot to add I am not rooted (if that makes a difference or not). and let me add that it was the official HTC 2.2 OTA upgrade.

    Thanks.
  4. Thread Author  Thread Author    #4  
    scramer's Avatar

    Posts
    74 Posts
    Global Posts
    75 Global Posts

    Default

    update: the main purpose for this was to switch out sd cards. after removing the battery to remove the sd card (and swapping out info the difficult way instead of using the phone as a drive i might add) and reinstalling the battery, I thought I might try again, the options are now available to me.

    Moral: try removing and reinstalling the battery.
  5. #5  

    Default

    I am haveing the same issue, not rooted, update is also officeial, let me know if you figure anything out for this.
  6. Thread Author  Thread Author    #6  
    scramer's Avatar

    Posts
    74 Posts
    Global Posts
    75 Global Posts

    Default

    Quote Originally Posted by rsheffey View Post
    I am haveing the same issue, not rooted, update is also officeial, let me know if you figure anything out for this.
    i fixed it by pulling the battery out, waiting a few minutes, then putting the battery back in.

Posting Permissions