05-14-2017 11:46 AM
37 12
tools
  1. djsusant's Avatar
    100% Workig Simple Steps:
    1. SWITCH OFF YOUR MOBILE DATA.
    2. SWITCH ON YOUR WI-FI.
    3. SWITCH ON FLIGHT MODE.
    4. RESTART YOUR PHONE. (KEEP ACTIVATED FLIGHT MODE & WI-FI)
    5. AFTER RESTART DON'T SWITCH OFF FLIGHT MODE.
    6. OPEN GOOGLE PLAY. WAIT FOR OPEN.
    SEE IT WILL OPEN GOOGLE APPS
    7. NOW YOU CAN SWITCH OFF FLIGHT MODE.
    12-18-2014 11:36 PM
  2. Billy Pehl's Avatar
    I did factory reset...it worked for me. Nothing else worked, i tried everything.
    12-20-2014 09:42 AM
  3. KyleK29's Avatar
    I've seen this on numerous android devices. It's generally related to the network stack not applying the proper DNS settings .. Some of you may have isolated it by testing the different security modes.

    The way I've fixed it (as suggested by another) is to force a static IP setting. So when joining the WiFi network, select "advanced settings" (I have 4.4 so I'm not sure if it's in the same place on other versions) and type in an IP# for your phone. Ideally, you'd want to do a DHCP reserve or have a block of IP#'s on your router that aren't in a DHCP pool. For me, I typed 192.168.0.240 as I have that set aside for statics.

    Gateway should populate, otherwise it's usually just the first 3 sets of numbers plus .1. Ie: 192.168.0.1

    For DNS, look up your ISP's local DNS servers. Type them in for DNS #1. I use an open DNS (not ISP related) for fallback on DNS #2. Google's DNS servers are 8.8.8.8 and 8.8.4.4

    Apply/connect. Test connection. This will also fix other apps. I had the issue with Yahoo Weather, among others.

    I do not recommend running your router in WEP mode. It's the easiest to crack.
    DefinitelyJoe likes this.
    12-30-2014 04:39 PM
  4. Venereo's Avatar
    For me doing the airplane mode on / off and then data off/on worked on my s5! 😀
    02-20-2015 09:38 AM
  5. delano thompson's Avatar
    Browser is working... every other app is working.... hence my frustrating :/
    Same
    08-26-2015 11:23 PM
  6. DefinitelyJoe's Avatar
    I've seen this on numerous android devices. It's generally related to the network stack not applying the proper DNS settings .. Some of you may have isolated it by testing the different security modes.

    The way I've fixed it (as suggested by another) is to force a static IP setting. So when joining the WiFi network, select "advanced settings" (I have 4.4 so I'm not sure if it's in the same place on other versions) and type in an IP# for your phone. Ideally, you'd want to do a DHCP reserve or have a block of IP#'s on your router that aren't in a DHCP pool. For me, I typed 192.168.0.240 as I have that set aside for statics.

    Gateway should populate, otherwise it's usually just the first 3 sets of numbers plus .1. Ie: 192.168.0.1

    For DNS, look up your ISP's local DNS servers. Type them in for DNS #1. I use an open DNS (not ISP related) for fallback on DNS #2. Google's DNS servers are 8.8.8.8 and 8.8.4.4

    Apply/connect. Test connection. This will also fix other apps. I had the issue with Yahoo Weather, among others.

    I do not recommend running your router in WEP mode. It's the easiest to crack.
    Christmas gifts for kids fixed. Thx for contribution!
    12-18-2015 12:03 PM
  7. fahimansari007's Avatar
    Thank you maria !!!
    It's Work...
    02-13-2016 01:09 AM
  8. Theghorap's Avatar
    Did u find any solution for this ?
    12-09-2016 03:27 AM
  9. srkmagnus's Avatar
    Did u find any solution for this ?
    Have you tried the solutions offered in this thread? If you are still having problems let us know.
    12-09-2016 12:11 PM
  10. Sherif Shaaban1's Avatar
    Recently, my wife's Samsung J5 (SM-J500H - android version 6.0.1) has started to behave weirdly. It can't access Google Play or Facebook network if it is over my home WiFi (D-Link 2750U router). But both services run flawlessly over data connection (3G). I tried everything. I factory-reset the phone, reset the router, checked device time settings, messed around with the router's security settings. Nothing worked.
    Then I tried a trick I read in one of the forums I ran through. I disabled the IPv6 from the router settings. Problem solved! I'm not a networking wizard. Don't know how this solved the problem, but I hope this helps. Thanks.
    12-19-2016 10:49 AM
  11. Jacques Briedenhann's Avatar
    Did u find any solution for this ?
    I just found a super easy fix. Didn't even have to reboot.

    My problem is not on a mobile device but on an android based media player. When I have an ethernet cable connected the play store works 100%. As soon as I switch to WiFi I can't open the play store due to the error about not being connected to wifi. Every other network/internet app works fine so I know it's not my connection.

    I spent hours troubleshooting, changing settings, re-configuring my wifi routers, etc etc. Nothing worked...

    Without further adieu. Browse to your device settings, find the date/time setting >> Disable Automatic date & time (Even if the date and time is correct). Confirm that date, time & time zone is correct. Return to play store and it should now be working.

    My device runs on Android 5.1.1
    04-16-2017 08:09 AM
  12. nicospanas's Avatar
    - Then just for checking I enabled / disabled "flight mode" after that I deactivated / activated "data network mode"
    - And i here i go, i got success.

    Google play is working fine with wifi and 3g as well.

    Hope it will help the needy

    Muhammad Adnan
    That worked for me! Thanks a lot.
    05-14-2017 11:46 AM
37 12

Similar Threads

  1. Dialer codes (*#*#4636#*#*) not working on Verizon Samsung Galaxy Note 2
    By pendraggon87 in forum General Help and How To
    Replies: 1
    Last Post: 02-21-2013, 02:26 PM
  2. YOUTUBE not working on my Samsung Galaxy Tablet 2 10.1
    By Richard Gough in forum Samsung Galaxy Tab 10-inch
    Replies: 1
    Last Post: 01-24-2013, 05:56 PM
  3. Google Play not working on Wifi or 3G...
    By TheIncredibleMrCool in forum Sprint Galaxy Nexus
    Replies: 1
    Last Post: 01-19-2013, 07:14 PM
  4. Google Talk not working on wifi
    By Jamma3 in forum Google / Samsung Galaxy Nexus
    Replies: 3
    Last Post: 12-15-2011, 02:25 PM
  5. help netflix not working on wifi
    By nycinter#AC in forum HTC EVO 4G
    Replies: 1
    Last Post: 08-16-2011, 02:06 AM
LINK TO POST COPIED TO CLIPBOARD