1. DirkBelig's Avatar
    I have Google and Facebook events show on my EVO's calendar. Since I keep a tight FB friends list, I don't mind the b-days showing. However, I said I'd be attending an online event from a FB contact that was set up as a daily thing for 7 hours and as a result, I've got it spamming my calendar view with four months worth of meetings. I went to FB and removed the event from my list there and went to the event page and said I wouldn't be attending, but even when I force sync the calendar, it's still showing up. Only turning off FB calendars entirely removes it, but the birthdays go with the bathwater. Is there any way to clear this that I'm overlooking? TIA!
    08-11-2010 10:06 PM
  2. DirkBelig's Avatar
    Nobody knows?
    08-14-2010 02:24 AM
  3. rsduncan1's Avatar
    Dirk - I am having the same problem A Facebook event that I am not even attending has filled everyday in my calendar (the BP boycott one) from May to September. Really annoying.

    I tried everything you did before reading this post. Hopefully someone else will have a solution.
    08-17-2010 03:49 PM
  4. bcbbanga4l's Avatar
    That was happening to me too actually. I had to go into the settings of the sync in settings and uncheck the facbook app where it says calendar and contacts i did both but all you would have to do is calendar. Hope that helps.
    08-17-2010 04:04 PM
  5. phaedrus05's Avatar
    I'm also having the same issue with a persistent event spamming my calendar. Can you provide a bit more detail as to how you fixed this? I changed the event to no longer attending and went in to the sync settings, but the only place I saw a calendar sync was under Google's sync-able items. Facebook and Facebook for HTC both only have contacts (and live feed for the latter) sync options.

    This is INDREDIBLY annoying.
    09-13-2010 05:16 PM
  6. BetaRoc's Avatar
    I had the same problem on my Captivate and had to unsync FB entirely.
    09-13-2010 08:17 PM
  7. mattydubs's Avatar
    phew! that sucked. i had same problem, and finally fixed it. on my evo, go settings > applications > manage applications > calendar storage > clear storage. then go to your calendar, notice that the recurring fb event is gone. as is every other event. just resync your fb and you should be good.
    DirkBelig likes this.
    10-23-2010 02:58 PM
  8. DirkBelig's Avatar
    phew! that sucked. i had same problem, and finally fixed it. on my evo, go settings > applications > manage applications > calendar storage > clear storage. then go to your calendar, notice that the recurring fb event is gone. as is every other event. just resync your fb and you should be good.
    YES!!!!! You = Da Man!!!
    10-23-2010 03:06 PM
  9. LeShandra's Avatar
    OMG! mattydubs you are a GENIUS! I was so irritated until I read and applied your post. THANK YOU!
    05-11-2011 10:59 AM
  10. CedricAnne97's Avatar
    Euhm... When I resync, it doesn't add the birthdays again.... What do I do now?
    07-08-2011 05:17 PM
  11. Daniel Pinner's Avatar
    Omg, you legend!!!! Thanks man.
    04-18-2013 10:25 AM
LINK TO POST COPIED TO CLIPBOARD