Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  

    Default Disable "Connected to Wi-Fi network [network name]" notification

    Hey everyone,

    I have a Galaxy S3 on the Bell Mobile network in Canada, and aside from the horrendous battery life, it's a pretty good phone. One thing I notice that's kinda annoying is the "Connected to Wi-Fi network [network name]" pop-up that comes up quite often. I've managed to snap a screenshot of it.

    Anyone know of how to disable this? The only info I've found so far is on the Verizon pop-ups, and entering the *#6335623# code on the dial screen, but nothing comes up when I try that, and I'm not even sure that fix would work for this.
    Attached Thumbnails Attached Thumbnails Disable "Connected to  Wi-Fi network [network name]" notification-screenshot_2013-06-11-18-22-01.png  
  2. #2  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Hi, and welcome to the forums. As far as I know, you can't disable that. It should only pop up for a second when you first connect. Are you seeing it more often than that? Like is the phone popping off and on the network repeatedly? If so, you might not have a good connection to it, so it jumps off to mobile data, then back onto the network and so on, resulting in repeat notifications everytime it manages to connect.
  3. Thread Author  Thread Author    #3  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    It usually pops up when I unlock the phone. For example, the phone will be off in my pocket, I'll get a text, then as I'm typing the first few words of my text, the notification pops up. And that happens very often when I unlock the phone, so its definitely not bad, just a nuisance, especially when I try to use the keys that are under the notification. My wireless internet isn't great, but I'm usually no more than 10 feet away from the router so...

    Either way thanks for the response.
  4. #4  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Hi, I just got my new S4 yesterday and I am using wifi at my work to connect to data. Well that wifi keeps disconnecting and connecting and getting that STUPID ***** ANNOYING popup again and again, every minute. As I do not have any control on this wifi netowork, looks like I have to live with it. But is there anyone who could let me know how to disable that? Any code/java,API call on Android OS? Anything will be helpful. It is making me crazy.
  5. #5  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Depends on version and carrier, but on stock 4.2/4.3 there's an option under the Wi-Fi settings to turn that off.

    Sent from my Nexus 4 using AC Forums mobile app
  6. #6  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Thanks for your quick response. I was a bit busy with my other activities. Also, I was trying to get a screen shot from Nexus 4.3 for advanced Wifi settings (tried to share screenshots here, but they are not showing up below). But I was not able to see any setting which would prevent the display on the screen whenever wifi is connected to a network. Is there any expert level coding or developer settings we can do to remove this? Thank you.

    Nexus
    Disable "Connected to  Wi-Fi network [network name]" notification-nexus.jpg

    Samsung Galaxy S4
    Disable "Connected to  Wi-Fi network [network name]" notification-wifi.jpg

    Annoying Wifi notification on my phone
    Disable "Connected to  Wi-Fi network [network name]" notification-annoying.jpg
    Last edited by chillwithme@gmail.com; 09-05-2013 at 02:02 PM.
  7. #7  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Did this ever get resolved?
  8. #8  
    srkmagnus's Avatar

    Posts
    8,191 Posts
    Global Posts
    8,194 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    Quote Originally Posted by Mark Anderle View Post
    Did this ever get resolved?
    What device do you have? Did you try looking through the wifi settings to disable notification of connected networks?
  9. #9  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    No it is not resolved, I updated my previous post with images. I am using Samsung Galaxy S4 and my previous post has the screenshot of wifi settings on it and also on Nexus. I cannot find any setting. It is really annoying to see that message popping once every minute or so.
  10. #10  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    An old thread I see but still an issue. I've just picked up an S4 to replace my old HTC and I have to say that this feature is really annoying. I've searched the net in vain for a solution. Does anybody have one?
  11. #11  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    I've searched through so many forums to a solution to this problem.

    Unfortunately, Kit-Kat 4.4 didn't fix this, either.

    Here's what I did to lessen the number of times I have to see that notification 'sticky note' appear:

    I run Juice Defender, which automatically disables/enables Wi-Fi every time you turn off your screen. As a result, Android notifies you when you reconnect to the network.

    Also, my network provider is Sprint, and they have a have a "Sprint Connections Optimizer," which essentially does the same thing, connecting and disconnecting as it pleases.


    I disabled Juice Defender and the Sprint Connections Optimizer, and have yet to see the 'Sticky Notification' return. If you are not disconnecting from the network every time you turn the screen off, it won't need to reconnect and notify you. The operating system by itself should stay connected.


    NOTE: These programs are used primarily to save battery. I haven't seen a dramatic decrease in battery life, but I think that's because 4.4 fixed a lot of issues in that realm.
  12. #12  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    I believe this 1 minute interval popup is generated by your wireless router. I changed from my 5 GHz band to the 2.4GHz band and it stopped for a few months. Recently it started again. Perhaps I need to go into the router and change some settings so it stops sending update signals to my phone. My router is a Netgear N600 Wireless Dual Band Router.
  13. #13  

    Default

    As moify noted, that notification comes up when the phone reconnects to the wireless network. If you stay connected to the wireless all the time you shouldn't see the notification often, if at all. I'm not sure how disabling wireless when the screen is off is a battery saver, it should use less power than using 4g.

    Moify, you didn't need Juice Defender to do that, it's a built-in feature of Android, it can be seen in the screen shots posted previously.

    Posted via Android Central App
  14. #14  

    Default Re: Disable "Connected to Wi-Fi network [network name]" notification

    I use the Netgear N600 Router
    Changed Wireless Settings to Enable Wireless Isolation on both bands.
    Check the Enable Wireless Isolation box. (on both bands).

    This fixed my problem. The message no longer appears.

Similar Threads

  1. phones won't connect to wi-fi
    By NicoleW78 in forum General Help and How To
    Replies: 5
    Last Post: 09-07-2013, 11:34 PM
  2. Unable to connect to Wi-Fi network
    By PackerBadger in forum Virgin Mobile Optimus V
    Replies: 7
    Last Post: 03-24-2011, 11:46 AM
  3. Replies: 16
    Last Post: 03-01-2011, 08:16 AM
  4. Moment not connecting to Wi-Fi
    By laughingperson5 in forum Samsung Moment
    Replies: 0
    Last Post: 06-24-2010, 01:08 AM
  5. Won't connect to Wi-Fi
    By clucas#AC in forum HTC Droid Eris
    Replies: 4
    Last Post: 03-25-2010, 10:32 AM

Posting Permissions