1. Jeremy W's Avatar
    Hi, All,
    I recently updated my Galaxy Note GT-N7000 to CyanogenMod 10.1.3 (Android 4.2.2) the other week. I don't know if it is related to the upgrade or not, but the phone no longer recognises the external SD card. I have tried three different cards (all 8GB), including a brand new class 10 bought this morning to test it. I've attached pictures of the storage page on the phone, showing that the phone sees the internal storage okay, and seems to recognise that there is an external card in (the "Space" and "Available" figures are correct), but that the mounting option is greyed out. I have checked all three cards in my Galaxy camera, which sees them okay. In addition, I booted into recovery mode (Vol+, Home, power) to see if the card was being recognised at that level, and I could see all the folders on the card then.

    I have spent the last three hours searching for solutions, but there is nothing of use except "the SD card is corrupt", which clearly isn't the case here since I've got three cards that all work in another Android device. Does anyone have any clues what the problem is, please?

    Thanks in advance!
    Attached Thumbnails External SD card not being recognised (N7000, CM10.1.3)-screenshot_2013-10-14-13-18-32.png   External SD card not being recognised (N7000, CM10.1.3)-screenshot_2013-10-14-13-18-43.png  
    10-14-2013 07:54 AM
  2. Golfdriver97's Avatar
    Have you tried using a different format?

    From a Sprint Moto X using AC forums app
    Jeremy W likes this.
    10-14-2013 08:23 AM
  3. Jeremy W's Avatar
    No, because the card had been working before the update. I have formatted the new card via the computer (because the phone won't recognise it to do a format!) to FAT32. However, now you've mentioned it, I'll format it in the Galaxy camera and see what happens then. Thanks for the thought.
    10-14-2013 08:51 AM
  4. Jeremy W's Avatar
    Ah, well - it was a good thought. It made no difference though - still the same as in the picture above.
    10-14-2013 09:04 AM
  5. Golfdriver97's Avatar
    No, because the card had been working before the update. I have formatted the new card via the computer (because the phone won't recognise it to do a format!) to FAT32. However, now you've mentioned it, I'll format it in the Galaxy camera and see what happens then. Thanks for the thought.
    Have you tried using NTFS?
    Jeremy W likes this.
    10-14-2013 09:09 AM
  6. Jeremy W's Avatar
    I have now - no joy. However, I don't know whether it is significant or not, but after reformatting to NTFS, then putting the card in the phone and rebooting to get the same picture as above, I put the card back in the computer just to see if all was still good, and found that LOST.DIR was written to it (I'm guessing during boot, since the date stamp is 01.01.2000, i.e. before the clock was set).

    Thanks for the ideas though - they might have occurred to me at some point in the future, but I'm not betting on it!
    10-14-2013 09:27 AM
  7. Golfdriver97's Avatar
    I am honestly at a loss for another solution. Be aware, however, that Android does not technically support SD cards anymore, so the error may be in the ROM.
    Jeremy W likes this.
    10-14-2013 09:32 AM
  8. Jeremy W's Avatar
    Thank you. I didn't know that Android itself has an issue with SD cards, though I was aware that Samsung devices were a bit flaky with them. I'll head off the the CyanogenMod forums to see what they say.
    10-14-2013 09:43 AM
  9. Golfdriver97's Avatar
    Thank you. I didn't know that Android itself has an issue with SD cards, though I was aware that Samsung devices were a bit flaky with them. I'll head off the the CyanogenMod forums to see what they say.
    Samsungs are flaky because they are forcing the SD card option on the OS. Anytime you force a computer to do something, it almost always leads to bad news.
    Jeremy W likes this.
    10-14-2013 09:57 AM
  10. Jeremy W's Avatar
    Anytime you force a computer to do something, it almost always leads to bad news.
    Truer words have rarely been spoken
    Golfdriver97 likes this.
    10-14-2013 10:02 AM
  11. Jeremy W's Avatar
    For completeness, I'll just pass on something else that didn't work. Booting into ClockworkMod and formatting the card from there leads to the same place. CWM sees the card happily, and formats and mounts it, but Android fails to mount it properly. Another small frustration, along with not being able to find the CSC so I can get my backups from Kies.
    Golfdriver97 likes this.
    10-14-2013 10:12 AM
  12. Jeremy W's Avatar
    Aaaand a final post (probably)

    I opened Astro File Manager last night to do something, and noticed that there was an entry for "sdcard1". I copied a couple of .jpgs across, and they transferred fine, and are accessible via the two gallery apps I have. I don't know what has happened - the "Storage" section in Settings still has it greyed out with a message to mount an SD card - but I can make use of the card at least in terms of transferring files. I haven't tried transferring any apps across (I use AppMgrIII) because I don't want to lose access to any of my apps suddenly, but I'll download an app I don't really need and see if I can transfer that across.

    So, in summary, it is strange, but the basic functionality is there
    10-16-2013 03:57 AM
  13. Back40BK's Avatar
    I am having the same problem, although the failure to read the sd card is intermittent. I turned the phone off and on a couple of times, removed and replaced the sd card, no luck. From Astro File Manager, I was able to look at the sd card and it appears that my photos have been deleted. Although there's other data still there, so I really don't get it. This is very frustrating and a real disappointment, especially since this upgrade seemed all about Gear which I have absolutely no interest in. And, my battery is still raining from the other recent upgrade. I would say these two upgrades have seriously reduced the functionality of this phone for me. Loved it up until now but won't recommend it to anyone.
    11-02-2013 08:25 PM
  14. Jeremy W's Avatar
    The external SD card seems to be working fine at the moment on mine, but I agree totally with the battery-use issue. I'm seriously thinking about going back to the Samsung 4.1.4 which had excellent battery life.
    11-03-2013 05:50 AM

Similar Threads

  1. Text Notifications or Alerts Not Showing Up - Verizon
    By kmp4life#AC in forum Samsung Galaxy Note 3
    Replies: 14
    Last Post: 01-27-2016, 11:51 AM
  2. S4 Official Case and S Voice not Working
    By DeanS4 in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 03-09-2014, 03:59 AM
  3. How to upgrade ICS to jelly Bean even our tablet's manufacturer did not release it officially??
    By Praveen Mylavarapu in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 10-14-2013, 08:39 AM
LINK TO POST COPIED TO CLIPBOARD
";