samsung s3 turn off notification light

In my settings for the LED indicator (blue flashing light when screen sleeps), I de-select the 'notifications' but the light still comes on when there is a missed call or message. I tried re-start and verified the setting, with the same result.

What do you advise?

Thank you