Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Can't send texts (SGS3)

    I can't seem to be able to send texts through the default messaging app. Calls and data works. Restarting my phone seems to temporarily fix my issue. I have full network bars and have tried switching carriers. I'm also on Android 4.3 on Samsung Galaxy S3.

    The weird thing is that I can send texts through Google Hangouts app, but not the android messaging app.

    Can anybody help me with this problem?

    Thanks
  2. #2  

    Default Re: Can't send texts (SGS3)

    Did you check your APN?

    Sent from my Nexus 4 using AC Forums mobile app
  3. Thread Author  Thread Author    #3  

    Default Re: Can't send texts (SGS3)

    Quote Originally Posted by gone down south View Post
    Did you check your APN?

    Sent from my Nexus 4 using AC Forums mobile app
    Hi, thanks for your reply

    I checked my APN and used the settings from
    Still doesn't work... I can sometimes send texts, but they usually show up after a few hours
  4. #4  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Can't send texts (SGS3)

    In Hangouts, make sure you go through the app settings to set the default app for sending SMS. This shouldn't really be the problem, but it's best to make sure the app you are using is enabled by default.

    If issues still exists then go through make sure the device is up to date on latest software and/or consider uninstall and reinstall the application you are using to send messages. If it's the stock app, then go to Settings > Applications > Messaging and clear cache. Don't clear data since that will delete your texts.
  5. Thread Author  Thread Author    #5  

    Default Re: Can't send texts (SGS3)

    Quote Originally Posted by srkmagnus View Post
    In Hangouts, make sure you go through the app settings to set the default app for sending SMS. This shouldn't really be the problem, but it's best to make sure the app you are using is enabled by default.

    If issues still exists then go through make sure the device is up to date on latest software and/or consider uninstall and reinstall the application you are using to send messages. If it's the stock app, then go to Settings > Applications > Messaging and clear cache. Don't clear data since that will delete your texts.
    Hello srkmagnus,
    I think you misunderstood my problem slightly. I can send texts through hangouts but I can't through the stock messaging app, which I prefer to use over hangouts. I already tried clearing cache and it didnt seem to work. Thanks for your reply anyways.

    Any additional help is appreciated!
  6. #6  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Can't send texts (SGS3)

    Quote Originally Posted by HoboEater View Post
    Hello srkmagnus,
    I think you misunderstood my problem slightly. I can send texts through hangouts but I can't through the stock messaging app, which I prefer to use over hangouts. I already tried clearing cache and it didnt seem to work. Thanks for your reply anyways.

    Any additional help is appreciated!
    Sorry, I completely misunderstood it. Have you gone into Google Hangouts > Settings > SMS > SMS Enabled (Under General). Change the way SMS are sent, for example, by selecting the stock messaging app.

    Hope that helps.

Similar Threads

  1. What can interfere with Knock On?
    By mrstarzan in forum LG G Pad 8.3
    Replies: 7
    Last Post: 02-10-2014, 11:31 AM
  2. How can I better protect my content?
    By PenguinLust in forum Samsung Galaxy Tab 3
    Replies: 5
    Last Post: 12-18-2013, 01:38 PM
  3. Replies: 33
    Last Post: 12-16-2013, 02:18 PM
  4. Replies: 3
    Last Post: 12-15-2013, 06:53 PM
  5. Galaxy S4 - Receiving texts takes longer after rooting?
    By jerkyg in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 12-15-2013, 01:53 PM

Posting Permissions

B