1. Aesthete18's Avatar
    I was helping my mom setup her new phone, I put in the sim card and each name has a duplicate with 1 number and 1 Whatsapp. I think there's some with Gmail as well. How do I combine it? I tried using GO Ex Contacts but it couldn't merge, it said there were no duplicates found, except 1 but with that contact both were numbers. There's about 400 contacts at the moment so it's gonna be a real pain to do it individually. Anyone know a fix? The phone is Samsung Galaxy Trend Plus.
    03-06-2014 12:49 AM
  2. nedia_r's Avatar
    If you sign into https://www.google.com/contacts/ on your computer. Select "more", there is an option to "find and merge duplicates". Hope that helps.
    03-06-2014 09:39 AM
  3. Aesthete18's Avatar
    If you sign into https://www.google.com/contacts/ on your computer. Select "more", there is an option to "find and merge duplicates". Hope that helps.
    There are no contacts under google>contacts. How do I get it up from my phone. Also, will this merge the contacts in the phone book as well?
    03-07-2014 10:06 PM
  4. nedia_r's Avatar
    I would turn contact syncing on. Then when they are all synced, delete them from the phone. And then merge any duplicates in Google contacts.
    03-10-2014 09:35 AM
  5. Bart van Lindert's Avatar
    I was helping my mom setup her new phone, I put in the sim card and each name has a duplicate with 1 number and 1 Whatsapp. I think there's some with Gmail as well. How do I combine it? I tried using GO Ex Contacts but it couldn't merge, it said there were no duplicates found, except 1 but with that contact both were numbers. There's about 400 contacts at the moment so it's gonna be a real pain to do it individually. Anyone know a fix? The phone is Samsung Galaxy Trend Plus.
    Same problem here. Some whatsapp contacts are merged with my contacts in the contact list but some are not. I cannot delete the Whatsapp contacts because they are read only. After trying for several days I have not found a method to merge the contacts. They do not appear in Google+ contacts. This really bugs me.
    03-14-2014 05:47 AM
  6. Bronyr's Avatar
    I'm fed up that there is no solution for those read only contacts. No matter what I tell whatsapp or Waze, those contacts still do appear in google only contacts but as read only, even when I try to catch the moment 'don't sync.' It's been so long and the app developers or mighty Google - none of them found any solutions.
    11-27-2014 11:02 PM
  7. diegoalvarezb's Avatar
    Same problem... Is there something new about that?

    When I edit the name of a contact name in google, it keeps the old one too (whatsapp readonly type). I don't know how to fix that.
    03-26-2015 10:20 AM
  8. marstupendo's Avatar
    i found out a simple way to fix that, in my phone at least.
    i edit the contact number (the google account number) so that it doesn't include any hyphens, and after saving, the contact shows only one number.
    it looks like if when the number contains hyphens, and i guess other formatting like apces or periods, the contact app doesn't understand they are the same number.
    sounds stupid right? well it worked in my phone.
    now i just have to look for an app to batch edit all my numbers! haven't found yet.
    i hope this helps you too.
    09-24-2015 08:40 AM
  9. PeterP007's Avatar
    In order to fix this (may be there is some SW update, because this still smells as a bug) do the following:
    1) Go to your contacts
    2) Select Contacts to display
    3) Select near the Customized list the"setting" sign
    4) Click on the arrow near to WhatsUp/Waze.... categories and unselect all not relevant checkboxes
    5) Now select the Customized list
    moon387 likes this.
    09-30-2015 05:30 AM
  10. moon387's Avatar
    Thanks to PeterP007...

    Hey Guys... I was also facing the same issue and there is a way to not show any whatsapp, viber etc. contacts in your phone contact list...
    I have Samsung Galaxy J.. new in market with Android Lollipop 5.1.

    Here what I did..

    1. Go to "Contacts".
    2. On top right corner "More"
    3. Click on "Settings"
    4. There in Settings you can see "Contacts to display".. just click it.
    5. Now it shows different options like Show All Contacts, Device Contacts, SIM Contacts, Whatsapp Contacts and of all accounts that you have. Simply select your desired option as mine was to show SIM Contacts.

    Note:
    All other Whatsapp etc. contacts are present but they won't be shown in your phone contact list. And you can change the setting whenever you want.

    I hope this help all..

    Regards
    Aebbeebo likes this.
    11-02-2015 11:05 PM
  11. Aebbeebo's Avatar
    Thanks to PeterP007...

    Hey Guys... I was also facing the same issue and there is a way to not show any whatsapp, viber etc. contacts in your phone contact list...
    I have Samsung Galaxy J.. new in market with Android Lollipop 5.1.

    Here what I did..

    1. Go to "Contacts".
    2. On top right corner "More"
    3. Click on "Settings"
    4. There in Settings you can see "Contacts to display".. just click it.
    5. Now it shows different options like Show All Contacts, Device Contacts, SIM Contacts, Whatsapp Contacts and of all accounts that you have. Simply select your desired option as mine was to show SIM Contacts.

    Note:
    All other Whatsapp etc. contacts are present but they won't be shown in your phone contact list. And you can change the setting whenever you want.

    I hope this help all..

    Regards
    Right Bro... quite effective for now.
    Let me check for couple of days, as no other problem creeps out #ThanksBuddy
    12-14-2015 07:03 AM
  12. Selector Spice's Avatar
    duplicate contacts come back and the "custom list" setting gets reset back to "All Contacts" once you open whatsapp again
    12-14-2015 10:15 AM
  13. Aebbeebo's Avatar
    resurfacing of the same problem...
    02-08-2016 09:02 AM
  14. itzdreaming's Avatar
    duplicate contacts come back and the "custom list" setting gets reset back to "All Contacts" once you open whatsapp again

    Yes... Once whats app opened it comes again. Any solution ?
    02-20-2016 10:24 PM
  15. singhaldipanshu's Avatar
    I might have just bumped into a possible solution. I was trying multiple solutions, and this one in particular worked (atleast for the time being).
    So, here it is,
    In the 'App Permissions' of WhatsApp, Go to the option of 'Write/Delete Contact' and change its permission from Always Allowed to Always Denied.
    Then after doing this, whatever contacts you save in your device from there on, save them individually, not by the add contact option of WhatsApp.
    It seems to have worked for me, though I have put this solution on probation as of now, as I cannot say the issue won't resurface prematurely.
    Thanks
    07-04-2016 11:06 PM
  16. Ryan Ebejer's Avatar
    Hi, I have an irritating problem on my android that I can't seem to solve. I will try to explain it as best I can. So, my contacts are stored in my gmail account and the people list is set to only show contacts I have on gmail. I also have whatsapp installed as well. now the problem is that when I press the phone icon to make a call and I press on the "enter a name or phone number" field to type a contact, the contacts are showing twice. one from gmail account (which I want) and the other of whatsapp. I know this because when I deleted whatsapp it started showing only the gmail contact. how do I get rid of the whatsapp contact showing up? I have gone through all the settings in whatsapp, people and the call screen numerous times. the only thing that worked is when I went in the contacts setting in whatsapp and deselected "show all contacts". but that way the messages in whatsapp will have no name just the number, so that's not a really good way. does anyone know how to solve it? preferably without uninstalling whatsapp.
    Thanks in advance
    11-11-2016 09:33 AM

Similar Threads

  1. Replies: 7
    Last Post: 03-07-2014, 07:09 PM
  2. I really need these Apps in Samsung Note 3, Please help?
    By kitharass in forum Samsung Galaxy Note 3
    Replies: 11
    Last Post: 03-06-2014, 07:50 PM
  3. What I miss in Swiftkey
    By emiinn in forum Samsung Galaxy Note 3
    Replies: 10
    Last Post: 03-06-2014, 11:31 AM
  4. How can someone contact GooglePlay to provide feedback.
    By Ghostnyc in forum General Help and How To
    Replies: 4
    Last Post: 03-05-2014, 09:21 PM
  5. Replies: 0
    Last Post: 03-05-2014, 07:01 PM
LINK TO POST COPIED TO CLIPBOARD