Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Unhappy Phone Contacts not appearing under Phone > People

    Morning,

    I am new to Android and the syncing features, while I'm sure useful if properly utilized, are creating a layer of complexity versus the iPhone (I have the HTC One M7). Please note that I am using this phone for work and personal purposes and do not want the two to mix. My work e-mail is through Gmail as well.

    So here is my first point of confusion / fear:

    -I added some contacts to my phone manually through the 'add contacts' option in the text messaging area
    -concern1: when going to my Phone > People the only thing that was showing was my twitter account (and some std options like taxi etc.) and the phone added my work e-mail to this twitter account.
    -concern2:side-concern related to above: Do I have to be concerned that by syncing my work contacts (all gmail) will be able to see my personal tweets etc.?
    -concern3: 1) the contacts I added as mentioned above do not show under Phone > People. In fact I added the same contact under phone > people and it is still showing 0 contacts. These people are not searchable from here either.

    Your help is appreciated!

    Thank you,

    C
  2. #2  
    Rukbat's Avatar

    Posts
    20,065 Posts
    Global Posts
    20,067 Global Posts
    Carrier
    Modified Stock 4.4.2

    Default Re: Phone Contacts not appearing under Phone > People

    That's because you're using an Android phone as if it was an iPhone. Contacts are added to Contacts (as Account contacts - ignore Phone and SIM contacts - you shouldn't use them in an Android phone). They're synced to Google. No one of your contacts can see any of the other of your contacts unless you give them your Google account password.

    If you start playing with things - like adding contacts through another app - the only one who can guarantee what's going to happen is the person who wrote that app.

    If the work you do is secure, and you need a phone that maintains security, you need a phone like a Samsung with Knox (with the actual program installed, nut just with the framework the phone comes with). And your IT department has to be familiar enough with Knox to make it work. Just playing with putting contacts in different places doesn't give you any security.
  3. #3  

    Default Re: Phone Contacts not appearing under Phone > People

    Were you able to find a solution to this? I'm having the same problem as the contacts I add/save to my phone aren't appearing in my People list either. I've saved contacts under the text messaging app as you have and the contacts can be seen there, but for some reason when I check the People list they're not added. I've also tried adding a contact directly in the People list and I get the notification saying the contact was saved but for some reason it's not being added to the list.
  4. #4  
    Rukbat's Avatar

    Posts
    20,065 Posts
    Global Posts
    20,067 Global Posts
    Carrier
    Modified Stock 4.4.2

    Default Re: Phone Contacts not appearing under Phone > People

    Check the menu in Contacts. See which contacts you have set in Contacts to display.
  5. #5  

    Default Re: Phone Contacts not appearing under Phone > People

    First of all restart your mobile after that check contacts which you want to enable or you can move your contacts into your sim card..

Similar Threads

  1. Phone goes black during use
    By fandroid18 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 04-25-2014, 10:03 AM
  2. Backup Contacts
    By cardboard60 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-25-2014, 07:26 AM

Posting Permissions