Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  

    Default 4.4.3 update not installing

    I have tried to install 4.4.3 on my Nexus 4, I got it OTA a couple of hours ago it has now been stuck on the "Installing system update" for about 1.5 hours now, the blue bar scrolls across and just resets at the start every few minutes.
    Any advice? I'm now not too bothered if I can have the update I just want my phone, can I just turn the phone off while it's on that screen? Do I leave it overnight attempting?

    Thanks
  2. Thread Author  Thread Author    #2  

    Default Re: 4.4.3 update not installing

    Scratch that, sorted it.
  3. #3  
    srkmagnus's Avatar

    Posts
    9,109 Posts
    Global Posts
    9,113 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: 4.4.3 update not installing

    Quote Originally Posted by Dave Morris1 View Post
    Scratch that, sorted it.
    Awesome. Did it finally complete or did you have to reboot the device?
  4. #4  

    Default Re: 4.4.3 update not installing

    Quote Originally Posted by Dave Morris1 View Post
    Scratch that, sorted it.
    I would also like to know what you did. I'm having the same problem with my Nexus 4.
  5. #5  

    Default Re: 4.4.3 update not installing

    I'm having the same issue with my Nexus 4. Last night I started the update, but this morning it was still updating.

    Does anyone no if I can just restart my device? Or are there other possibilities?
  6. #6  

    Default Re: 4.4.3 update not installing

    If found this at another board: 4.4.3 update

    I too was stuck on the ""Installing System Update..." for about 30 minutes. There's no way a 80MB upgrade would need that much time, so I pressed the power button for a few seconds. It then flashed the screen, showed the Google logo and it resumed the "Installing System Update" with the blue progress bar moving.

    However, this time it finished the upgrade in just one cycle. After that it went to the Android Is Upgrading with all the apps getting "optimized" as usual. After it finished that, it is now up and running as usual and shows version 4.4.3 in the About page.

    This was upgraded from 4.2.2, unrooted, purchased from the Google Play store. I did the Download and Install over Wifi, on battery power, no USB connection. After a few minutes of playing with it, I haven't noticed any issues, but I haven't put it through a test of everything I do either...
    and


    I had the exact issue. Press-and-holding the Power button rebooted it and then it finished completely. It only did one blue progress bar cycle and then continued with the usual update. I didn't time how long I was press-and-holding the Power button but I don't think it was more than 20 seconds or so.
    Thanked by:
  7. #7  

    Default Re: 4.4.3 update not installing

    Can someone please post a tutorial on how to install 4.4.3 without using adb? I have it downloaded on my N7 but i cant open it using a file mgr and i cant booti nto the bootloader to install it that way. It was a easy install on my moto x and with the N7 its one big ******* hassle. TIA
    The "infraction"
  8. #8  

    Default Re: 4.4.3 update not installing

    Same issue here. Holding down the power button fixed it, thanks a lot!

Similar Threads

  1. Replies: 4
    Last Post: 10-07-2014, 07:53 AM
  2. Just got 4.4.3 update notification
    By amroa in forum Google Play edition HTC One (M8)
    Replies: 10
    Last Post: 06-11-2014, 08:26 PM
  3. Replies: 3
    Last Post: 06-05-2014, 09:34 AM
  4. Replies: 2
    Last Post: 06-04-2014, 04:03 PM
  5. Replies: 1
    Last Post: 06-04-2014, 03:48 PM

Posting Permissions